summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-09 19:13:42 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-09 19:16:22 +0100
commitcdbd6e87f6fae413899189a9a363f8d61e16016c (patch)
tree0bb78230641c96981775152a6c1c4a24914d8e04 /media-gfx/ristretto/ristretto-0.13.0.ebuild
parentapp-editors/mousepad: Bump to 0.6.0 (diff)
downloadgentoo-cdbd6e87f6fae413899189a9a363f8d61e16016c.tar.gz
gentoo-cdbd6e87f6fae413899189a9a363f8d61e16016c.tar.bz2
gentoo-cdbd6e87f6fae413899189a9a363f8d61e16016c.zip
media-gfx/ristretto: Bump to 0.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-gfx/ristretto/ristretto-0.13.0.ebuild')
-rw-r--r--media-gfx/ristretto/ristretto-0.13.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-gfx/ristretto/ristretto-0.13.0.ebuild b/media-gfx/ristretto/ristretto-0.13.0.ebuild
new file mode 100644
index 000000000000..424f774a12a1
--- /dev/null
+++ b/media-gfx/ristretto/ristretto-0.13.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A fast and lightweight picture viewer for Xfce"
+HOMEPAGE="
+ https://docs.xfce.org/apps/ristretto/start
+ https://gitlab.xfce.org/apps/ristretto/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.56:2
+ media-libs/libexif:0=
+ sys-apps/file
+ x11-libs/cairo:0
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11:0=
+ >=xfce-base/libxfce4ui-4.16:0=
+ >=xfce-base/libxfce4util-4.16:0=
+ >=xfce-base/xfconf-4.12.1:0=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}