summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/qiv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/qiv')
-rw-r--r--media-gfx/qiv/Manifest2
-rw-r--r--media-gfx/qiv/metadata.xml8
-rw-r--r--media-gfx/qiv/qiv-2.2.4.ebuild44
-rw-r--r--media-gfx/qiv/qiv-2.3.1.ebuild64
4 files changed, 118 insertions, 0 deletions
diff --git a/media-gfx/qiv/Manifest b/media-gfx/qiv/Manifest
new file mode 100644
index 000000000000..c9236f6658bc
--- /dev/null
+++ b/media-gfx/qiv/Manifest
@@ -0,0 +1,2 @@
+DIST qiv-2.2.4.tgz 98874 SHA256 ed6078dc550c1dc2fe35c1e0f46463c13589a24b83d4f7101b71a7485e51abb7 SHA512 744014ff70c9397d7a90e60740f482976713c9e5ff295a03684ae7b50ae70b86589d9e9066702fd43241bf2767c3537f582aab5ebbde25caea1663ec825f76a5 WHIRLPOOL 4587a9f467bf5bd0cb35040372bb3d445e900f0c93f44f186b939afedd9d2ea0a707c91b63987857c9bf9ead3a943fabb72a87f3e3b9f8256932ec3304dbb213
+DIST qiv-2.3.1.tgz 130621 SHA256 675396b539e6511135fe73c867f9fdd6d912c24c7562797cb047c27d0c2c8ee6 SHA512 5a9b8ac082c78071c903e2f10a98effc412c0b6b940437b6592077978de03b5c7b6192e4d696f0389c12e99e0d3b5ca40c3be54ca2dfa5439121af2415f32812 WHIRLPOOL c890059062ca33886b34ea2cf146854431770af03cf5720c205dfd494023b64297b536decc70fe6b8a8b2a7879a4917f3dfd496d1e207dbb92d28d5114b32d06
diff --git a/media-gfx/qiv/metadata.xml b/media-gfx/qiv/metadata.xml
new file mode 100644
index 000000000000..978159afc5ac
--- /dev/null
+++ b/media-gfx/qiv/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <use>
+ <flag name="magic">Use libmagic to determine mimetypes</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-gfx/qiv/qiv-2.2.4.ebuild b/media-gfx/qiv/qiv-2.2.4.ebuild
new file mode 100644
index 000000000000..5acf9ba2f1fb
--- /dev/null
+++ b/media-gfx/qiv/qiv-2.2.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="Quick Image Viewer"
+HOMEPAGE="http://spiegl.de/qiv/"
+SRC_URI="http://spiegl.de/qiv/download/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="xinerama"
+
+RDEPEND=">=x11-libs/gtk+-2.12:2
+ media-libs/imlib2[X]
+ !<media-gfx/pqiv-0.11
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e 's:$(CC) $(CFLAGS):$(CC) $(LDFLAGS) $(CFLAGS):' \
+ Makefile || die
+
+ if ! use xinerama; then
+ sed -i \
+ -e 's:-DGTD_XINERAMA::' \
+ Makefile || die
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin qiv
+ doman qiv.1
+ dodoc Changelog qiv-command.example README README.TODO
+}
diff --git a/media-gfx/qiv/qiv-2.3.1.ebuild b/media-gfx/qiv/qiv-2.3.1.ebuild
new file mode 100644
index 000000000000..12fbd0137b7a
--- /dev/null
+++ b/media-gfx/qiv/qiv-2.3.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs eutils fdo-mime gnome2-utils
+
+DESCRIPTION="Quick Image Viewer"
+HOMEPAGE="http://spiegl.de/qiv/"
+SRC_URI="http://spiegl.de/qiv/download/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="exif lcms magic"
+
+RDEPEND=">=x11-libs/gtk+-2.12:2
+ media-libs/imlib2[X]
+ exif? ( media-libs/libexif )
+ lcms? ( media-libs/lcms:2 )
+ magic? ( sys-apps/file )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e 's:$(CC) $(CFLAGS):$(CC) $(LDFLAGS) $(CFLAGS):' \
+ Makefile || die
+
+ if ! use exif ; then
+ sed -i 's/^EXIF =/#\0/' Makefile || die
+ fi
+
+ if ! use lcms ; then
+ sed -i 's/^LCMS =/#\0/' Makefile || die
+ fi
+
+ if ! use magic ; then
+ sed -i 's/^MAGIC =/#\0/' Makefile || die
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin qiv
+ doman qiv.1
+ dodoc Changelog contrib/qiv-command.example README README.TODO
+
+ domenu qiv.desktop
+ doicon qiv.png
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}