summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/pqiv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/pqiv')
-rw-r--r--media-gfx/pqiv/Manifest1
-rw-r--r--media-gfx/pqiv/metadata.xml12
-rw-r--r--media-gfx/pqiv/pqiv-2.2.ebuild42
3 files changed, 55 insertions, 0 deletions
diff --git a/media-gfx/pqiv/Manifest b/media-gfx/pqiv/Manifest
new file mode 100644
index 000000000000..00d42ffdf615
--- /dev/null
+++ b/media-gfx/pqiv/Manifest
@@ -0,0 +1 @@
+DIST pqiv-2.2.tar.gz 52414 SHA256 88d625de4437c8e65a49d74e993df5debf224ecf726365e138bf90a602b8b74b SHA512 2f504e228607b4b7b3cb341def5a104c86d932dc93f54b68893acbf5becc9cfa5c4d7549ead8ee25c4cb1f6a3cf13623eb3836e368299de2a21624d9773458bc WHIRLPOOL 0df549d3cc686806413741e453335e7e54f1e194c4296ccc9a72f9b6805b5f83514ee6dbdb45478753c91d36b7baf6b1bf88abb5f84ea9fb1c1bf9643c4fe2f9
diff --git a/media-gfx/pqiv/metadata.xml b/media-gfx/pqiv/metadata.xml
new file mode 100644
index 000000000000..09572f4b3efe
--- /dev/null
+++ b/media-gfx/pqiv/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <upstream>
+ <maintainer>
+ <email>phillip.berndt@googlemail.com</email>
+ <name>Phillip Berndt</name>
+ </maintainer>
+ <remote-id type="github">phillipberndt/pqiv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-gfx/pqiv/pqiv-2.2.ebuild b/media-gfx/pqiv/pqiv-2.2.ebuild
new file mode 100644
index 000000000000..e30911ee9191
--- /dev/null
+++ b/media-gfx/pqiv/pqiv-2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="Modern rewrite of Quick Image Viewer"
+HOMEPAGE="http://github.com/phillipberndt/pqiv http://www.pberndt.com/Programme/Linux/pqiv/"
+SRC_URI="https://github.com/phillipberndt/pqiv/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="kernel_linux"
+
+RDEPEND=">=dev-libs/glib-2.8:2
+ >=x11-libs/cairo-1.6
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~INOTIFY_USER"
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ ./configure --prefix=/usr --destdir="${D}" || die
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ default
+ dodoc README.markdown
+}