summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-06-30 12:56:54 +1000
committerMichael Palimaka <kensington@gentoo.org>2018-06-30 12:57:57 +1000
commit2920ec9b0299696ae96723dee72ab404e2e53d4a (patch)
treed0377558d8fd792d561b8638f9f54dc0d4408834 /media-gfx/phototonic
parentmedia-video/gaupol: add myself as maintainer (diff)
downloadgentoo-2920ec9b0299696ae96723dee72ab404e2e53d4a.tar.gz
gentoo-2920ec9b0299696ae96723dee72ab404e2e53d4a.tar.bz2
gentoo-2920ec9b0299696ae96723dee72ab404e2e53d4a.zip
media-gfx/phototonic: version bump 2.1
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'media-gfx/phototonic')
-rw-r--r--media-gfx/phototonic/Manifest1
-rw-r--r--media-gfx/phototonic/phototonic-2.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/media-gfx/phototonic/Manifest b/media-gfx/phototonic/Manifest
index 54755d057903..e1169d8ffb9d 100644
--- a/media-gfx/phototonic/Manifest
+++ b/media-gfx/phototonic/Manifest
@@ -1,2 +1,3 @@
DIST phototonic-1.6.17.tar.xz 167264 BLAKE2B 39df863da3084454fbde2f4a02f4b4251be2487d0bb7628fb20a8a6b4ade653ea93324262815ac1f2d778310941f27d73b34ed6dc71aeade9a7236350674b011 SHA512 66c537c723b114de8a92692933a3671346919dde1ce028a9c067909403d91c0a161d5887e0c07e9309d524179308364fc93403c608b3226d74e28bc744e08cde
DIST phototonic-2.0.tar.gz 283185 BLAKE2B 0c86fa991fd2c05721d19c603becd27f93139377416ff4c9b2749488c5d5753263d3223d3bd71d3a4670289243b471ccdcb7f937d2f080cbd7dd6442cf7257f4 SHA512 e72952c76332b592043a39a4920ab941f20b3494d66e9855becf09438e36c0edbdbf1a384a08a9b825c5e48ac4c87b5e4cb7d1eaff7076140ad2537868aa4357
+DIST phototonic-2.1.tar.gz 488640 BLAKE2B bfbc14d06760c6f9d9244d5ed38d033a769f1eaf8116f55ea6aa5373578aa105fd28ef8e352d394939306af2ab3b617314aebc443a13f7abe9bb8be2fd0cb0cd SHA512 4789311cefa2d5a07ca5e2fd3c0530267f9ea2ffcbf6295c687db3d2aa55e0b7d91228047b2ca24590868b22ce93d0228785fcf49a105ee65c9826b0d9a8fa42
diff --git a/media-gfx/phototonic/phototonic-2.1.ebuild b/media-gfx/phototonic/phototonic-2.1.ebuild
new file mode 100644
index 000000000000..46087619b847
--- /dev/null
+++ b/media-gfx/phototonic/phototonic-2.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils qmake-utils xdg-utils
+
+DESCRIPTION="Image viewer and organizer"
+HOMEPAGE="https://github.com/oferkv/phototonic"
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/oferkv/phototonic.git"
+else
+ SRC_URI="https://github.com/oferkv/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="svg tiff"
+
+RDEPEND="
+ dev-qt/qtwidgets:5
+ dev-qt/qtgui:5
+ dev-qt/qtcore:5
+ media-gfx/exiv2:=
+ svg? ( dev-qt/qtsvg:5 )
+ tiff? ( dev-qt/qtimageformats:5 )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}