summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/nip2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/nip2')
-rw-r--r--media-gfx/nip2/Manifest1
-rw-r--r--media-gfx/nip2/files/nip2-7.16.4-fftw3-build.patch12
-rw-r--r--media-gfx/nip2/metadata.xml8
-rw-r--r--media-gfx/nip2/nip2-7.26.4.ebuild78
4 files changed, 99 insertions, 0 deletions
diff --git a/media-gfx/nip2/Manifest b/media-gfx/nip2/Manifest
new file mode 100644
index 000000000000..bfb6edb02020
--- /dev/null
+++ b/media-gfx/nip2/Manifest
@@ -0,0 +1 @@
+DIST nip2-7.26.4.tar.gz 8700478 SHA256 0344420f7da39efc7011e552528db9651ebbbe1c6d26b8c11d0ccfaae20f34a8
diff --git a/media-gfx/nip2/files/nip2-7.16.4-fftw3-build.patch b/media-gfx/nip2/files/nip2-7.16.4-fftw3-build.patch
new file mode 100644
index 000000000000..d67134638502
--- /dev/null
+++ b/media-gfx/nip2/files/nip2-7.16.4-fftw3-build.patch
@@ -0,0 +1,12 @@
+=== modified file 'configure.in'
+--- configure.in 2009-01-13 09:30:52 +0000
++++ configure.in 2009-01-13 09:35:48 +0000
+@@ -186,6 +186,7 @@
+ with_fftw3=no
+ ])
+ IP_CFLAGS="$FFTW_INCLUDES $FFTW3_CFLAGS $IP_CFLAGS"
++ IP_LIBS="$FFTW3_LIBS $IP_LIBS"
+ fi
+
+ # optional ... we add some gsl funcs as builtins if available
+
diff --git a/media-gfx/nip2/metadata.xml b/media-gfx/nip2/metadata.xml
new file mode 100644
index 000000000000..91ac8ee94a6b
--- /dev/null
+++ b/media-gfx/nip2/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <use>
+ <flag name='goffice'>use <pkg>x11-libs/goffice</pkg> to show plots</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-gfx/nip2/nip2-7.26.4.ebuild b/media-gfx/nip2/nip2-7.26.4.ebuild
new file mode 100644
index 000000000000..b4f61fb35053
--- /dev/null
+++ b/media-gfx/nip2/nip2-7.26.4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils autotools fdo-mime gnome2-utils versionator
+
+MY_MAJ_VER=$(get_version_component_range 1-2)
+DESCRIPTION="VIPS Image Processing Graphical User Interface"
+SRC_URI="http://www.vips.ecs.soton.ac.uk/supported/${MY_MAJ_VER}/${P}.tar.gz"
+HOMEPAGE="http://vips.sourceforge.net"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug fftw goffice gsl test"
+
+RDEPEND=">=dev-libs/glib-2.14:2
+ dev-libs/libxml2
+ x11-misc/xdg-utils
+ >=media-libs/vips-${MY_MAJ_VER}
+ >=x11-libs/gtk+-2.18:2
+ goffice? ( x11-libs/goffice:0.8 )
+ gsl? ( sci-libs/gsl )
+ fftw? ( sci-libs/fftw:3.0 )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ test? ( media-libs/vips[jpeg,lcms,tiff] )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-7.16.4-fftw3-build.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-update-desktop \
+ $(use_enable debug) \
+ $(use_with goffice libgoffice) \
+ $(use_with gsl) \
+ $(use_with fftw fftw3)
+}
+
+src_test() {
+ if ! use gsl; then
+ ewarn "Some tests require USE=gsl. Disabling test_math.ws tests."
+ rm test/workspaces/test_math.ws
+ fi
+ make check || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README* || die
+ insinto /usr/share/icons/hicolor/128x128/apps
+ newins share/nip2/data/vips-128.png nip2.png || die
+
+ mv "${D}"/usr/share/doc/${PN}/* "${D}"/usr/share/doc/${PF} || die
+ rmdir "${D}"/usr/share/doc/${PN}/ || die
+ dosym /usr/share/doc/${PF}/html /usr/share/doc/${PN}/
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}