summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-06 19:32:52 +0100
committerSam James <sam@gentoo.org>2020-09-06 19:36:24 +0100
commit0a0118d6d8576e7a0182af1d517b16a85a7f49b1 (patch)
tree248899200e74d94114ca2b9a4afc5eca1484dcc0 /media-gfx/mypaint
parentdev-libs/ell: ppc64 stable (bug #736541) (diff)
downloadgentoo-0a0118d6d8576e7a0182af1d517b16a85a7f49b1.tar.gz
gentoo-0a0118d6d8576e7a0182af1d517b16a85a7f49b1.tar.bz2
gentoo-0a0118d6d8576e7a0182af1d517b16a85a7f49b1.zip
media-gfx/mypaint: patch out openmp flag
We'll return to whether we want USE=openmp later on, but there's no point for now, as it's being added unconditionally and libmypaint's openmp is causing a crash right now. Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/mypaint')
-rw-r--r--media-gfx/mypaint/files/mypaint-2.0.1-build-system.patch15
-rw-r--r--media-gfx/mypaint/mypaint-2.0.1.ebuild5
2 files changed, 20 insertions, 0 deletions
diff --git a/media-gfx/mypaint/files/mypaint-2.0.1-build-system.patch b/media-gfx/mypaint/files/mypaint-2.0.1-build-system.patch
index 63a7a5bf75ed..c7806e7119dc 100644
--- a/media-gfx/mypaint/files/mypaint-2.0.1-build-system.patch
+++ b/media-gfx/mypaint/files/mypaint-2.0.1-build-system.patch
@@ -20,3 +20,18 @@ index 670df4d..703f9d2 100644
]
extra_link_args = []
+diff --git a/setup.py b/setup.py
+index 703f9d2..cc8abbd 100644
+--- a/setup.py
++++ b/setup.py
+@@ -456,10 +456,6 @@ class BuildExt (build_ext):
+ ccflags = ext.extra_compile_args
+ linkflags = ext.extra_link_args
+
+- if sys.platform != "darwin" and not self.disable_openmp:
+- linkflags.append(OPENMP_CFLAG)
+- ccflags.append(OPENMP_LDFLAG)
+-
+ if self.debug:
+ skip = ["-DNDEBUG"]
+ ccflags[:] = [f for f in ccflags if f not in skip]
diff --git a/media-gfx/mypaint/mypaint-2.0.1.ebuild b/media-gfx/mypaint/mypaint-2.0.1.ebuild
index ac43f1303cf4..1ca2e261568c 100644
--- a/media-gfx/mypaint/mypaint-2.0.1.ebuild
+++ b/media-gfx/mypaint/mypaint-2.0.1.ebuild
@@ -50,6 +50,11 @@ PATCHES=(
distutils_enable_tests setup.py
+# TODO: Allow openmp support (patched out)
+# There's no urgency on this given that it currently
+# breaks runtime use [0]
+# [0] https://github.com/mypaint/mypaint/issues/1107.
+
src_install() {
distutils-r1_src_install