summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/iscan-plugin-gt-f500
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/iscan-plugin-gt-f500')
-rw-r--r--media-gfx/iscan-plugin-gt-f500/Manifest1
-rw-r--r--media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1-r1.ebuild85
-rw-r--r--media-gfx/iscan-plugin-gt-f500/metadata.xml26
3 files changed, 112 insertions, 0 deletions
diff --git a/media-gfx/iscan-plugin-gt-f500/Manifest b/media-gfx/iscan-plugin-gt-f500/Manifest
new file mode 100644
index 000000000000..9fbaceed7d4e
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-f500/Manifest
@@ -0,0 +1 @@
+DIST iscan-plugin-gt-f500-1.0.0-1.c2.i386.rpm 126130 SHA256 fe87d16ce22c28e2c320286758bea32ea4cad75c83debd6fe95670b704701464 SHA512 efecbb6e3f4fe3f498ebf9bb68a1755405c675d67c52042dcfc2e4e7f98903a870f969b4453d110c9f774452c6ae44042482ee954762c5f5a559e2d3e52a98d0 WHIRLPOOL 11ac8ac1e40b95a2a6128fc3c7fca8c27483c8305f87c989d4102b3d26acd655d7436c7a11547e8c08dac2a488c98b16699e801a5e794f6122935e91116b9bce
diff --git a/media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1-r1.ebuild b/media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1-r1.ebuild
new file mode 100644
index 000000000000..d6fae4f83946
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit multilib rpm versionator
+
+MY_P="${PN}-$(replace_version_separator 3 -)"
+
+DESCRIPTION="Epson Perfection 2480/2580 PHOTO scanner plugin for SANE 'epkowa' backend"
+HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+SRC_URI="http://dev.gentoo.org/~flameeyes/avasys/${MY_P}.c2.i386.rpm"
+
+LICENSE="EPSON EAPL"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+IUSE="minimal"
+
+DEPEND="minimal? ( >=media-gfx/iscan-2.21.0 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ # install scanner firmware
+ insinto /usr/share/iscan
+ doins "${WORKDIR}/usr/share/iscan/"*
+
+ dodoc usr/share/doc/*/*
+
+ use minimal && return
+ # install scanner plugins
+ exeinto /opt/iscan/esci
+ doexe "${WORKDIR}/usr/$(get_libdir)/iscan/"*
+}
+
+pkg_setup() {
+ basecmds=(
+ "iscan-registry --COMMAND interpreter usb 0x04b8 0x0121 '/opt/iscan/esci/libesint41.so.2 /usr/share/iscan/esfw41.bin'"
+ )
+}
+
+pkg_postinst() {
+ elog
+ elog "Firmware file esfw41.bin for Epson Perfection 2480/2580 PHOTO"
+ elog "has been installed in /usr/share/iscan."
+ elog
+ use minimal && return
+ [[ -n ${REPLACING_VERSIONS} ]] && return
+
+ # Needed for scanner to work properly.
+ if [[ ${ROOT} == "/" ]]; then
+ for basecmd in "${basecmds[@]}"; do
+ eval ${basecmd/COMMAND/add}
+ done
+ else
+ ewarn "Unable to register the plugin and firmware when installing outside of /."
+ ewarn "execute the following command yourself:"
+ for basecmd in "${basecmds[@]}"; do
+ ewarn "${basecmd/COMMAND/add}"
+ done
+ fi
+}
+
+pkg_prerm() {
+ use minimal && return
+ [[ -n ${REPLACED_BY_VERSION} ]] && return
+
+ if [[ ${ROOT} == "/" ]]; then
+ for basecmd in "${basecmds[@]}"; do
+ eval ${basecmd/COMMAND/remove}
+ done
+ else
+ ewarn "Unable to de-register the plugin and firmware when installing outside of /."
+ ewarn "execute the following command yourself:"
+ for basecmd in "${basecmds[@]}"; do
+ ewarn "${basecmd/COMMAND/remove}"
+ done
+ fi
+}
diff --git a/media-gfx/iscan-plugin-gt-f500/metadata.xml b/media-gfx/iscan-plugin-gt-f500/metadata.xml
new file mode 100644
index 000000000000..2f94838d7dff
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-f500/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Proprietary plugin for several EPSON scanner models, to be used
+ with the epkowa SANE backend (provided by
+ <pkg>media-gfx/iscan</pkg>). 32-bit only.
+
+ Also includes the firmware for them, to be used with the snapscan
+ SANE backend (provided by <pkg>media-gfx/sane-backends</pkg>).
+
+ Supports the following models:
+
+ EPSON Perfection 2480 PHOTO / GT-F500
+ EPSON Perfection 2580 PHOTO / GT-F550
+ </longdescription>
+
+ <use>
+ <flag name='minimal'>
+ Install the firmware only, and not the plugin.
+ </flag>
+ </use>
+</pkgmetadata>