summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/iscan-data
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/iscan-data')
-rw-r--r--media-gfx/iscan-data/Manifest2
-rw-r--r--media-gfx/iscan-data/iscan-data-1.22.0.1.ebuild43
-rw-r--r--media-gfx/iscan-data/iscan-data-1.36.0.1.ebuild47
-rw-r--r--media-gfx/iscan-data/metadata.xml14
4 files changed, 106 insertions, 0 deletions
diff --git a/media-gfx/iscan-data/Manifest b/media-gfx/iscan-data/Manifest
new file mode 100644
index 000000000000..ec4f92ad79ce
--- /dev/null
+++ b/media-gfx/iscan-data/Manifest
@@ -0,0 +1,2 @@
+DIST iscan-data_1.22.0-1.tar.gz 96626 SHA256 e6ef1c275488d907869f48eb7889d9a01e564ea4b39e291e90843feb59e92ef8 SHA512 2adc6c125045803ffd269abab4f58d6d1c87ebd4c959985e6689d0b2e7f5a84fb1956d0e559c35b1704a1e330bc639e668c37f718c871e076a7ccf6c35562e6f WHIRLPOOL f4b7aaf68396c54295b40999653b4f1f8777d154e38ff1612a2458c2449570a6213fd41abeb13d6d06cba09828f8f35d485a6cce7303e8657a7ce87887657cc2
+DIST iscan-data_1.36.0-1.tar.gz 100218 SHA256 3a0a0075d0f7fcb0f482cbde2e74c9f6bee64268db32a4e6f470f1a6069117ba SHA512 a9711264c852dd4bdcdb10c1153f725a111bd74b03705c99265b6692bf47236c6e4f5e7e4813991eb5991deb198adeee272c8c3eb53da641ba189d923916d3cb WHIRLPOOL 5fc6bc042c7ee587e00b47f46f7b3ae3eba8646ac8c66ea5a1641d616f54fe75e7a1285b7146a4bba0e75bb88dae8c4478cefc270f6bf07e89f67b6ec3141f02
diff --git a/media-gfx/iscan-data/iscan-data-1.22.0.1.ebuild b/media-gfx/iscan-data/iscan-data-1.22.0.1.ebuild
new file mode 100644
index 000000000000..9bf1319e1e62
--- /dev/null
+++ b/media-gfx/iscan-data/iscan-data-1.22.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils versionator udev multilib
+
+MY_PV="$(get_version_component_range 1-3)"
+MY_PVR="$(replace_version_separator 3 -)"
+
+DESCRIPTION="Image Scan! for Linux data files"
+HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+SRC_URI="http://dev.gentoo.org/~flameeyes/avasys/${PN}_${MY_PVR}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="amd64 x86"
+IUSE="udev"
+
+DEPEND="udev? (
+ dev-libs/libxslt
+ media-gfx/sane-backends
+ )"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DOCS=( NEWS SUPPORTED-DEVICES KNOWN-PROBLEMS )
+
+src_install() {
+ default
+
+ if use udev; then
+ # create udev rules
+ local rulesdir=$(get_udevdir)/rules.d
+ dodir ${rulesdir}
+ "${D}usr/$(get_libdir)/iscan-data/make-policy-file" \
+ --force --quiet --mode udev \
+ -d "${D}usr/share/iscan-data/epkowa.desc" \
+ -o "${D}${rulesdir}/99-iscan.rules" || die
+ fi
+}
diff --git a/media-gfx/iscan-data/iscan-data-1.36.0.1.ebuild b/media-gfx/iscan-data/iscan-data-1.36.0.1.ebuild
new file mode 100644
index 000000000000..5653548c69d3
--- /dev/null
+++ b/media-gfx/iscan-data/iscan-data-1.36.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils versionator udev multilib
+
+MY_PV="$(get_version_component_range 1-3)"
+MY_PVR="$(replace_version_separator 3 -)"
+
+DESCRIPTION="Image Scan! for Linux data files"
+HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+# Use a gentoo hosted url since upstream uses a session based url that causes the
+# files to no longer be available after the session expires.
+SRC_URI="http://dev.gentoo.org/~idella4/tarballs//${PN}_${MY_PVR}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="amd64 x86"
+IUSE="udev"
+
+DEPEND="udev? (
+ dev-libs/libxslt
+ media-gfx/sane-backends
+ )"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DOCS=( NEWS SUPPORTED-DEVICES KNOWN-PROBLEMS )
+
+src_install() {
+ ewarn ""; ewarn "Some profiles automatically enable udev which will cause install to fail"
+ ewarn "if media-gfx/sane-backends is not already installed."; ewarn ""
+ default
+
+ if use udev; then
+ # create udev rules
+ local rulesdir=$(get_udevdir)/rules.d
+ dodir ${rulesdir}
+ "${D}usr/$(get_libdir)/iscan-data/make-policy-file" \
+ --force --mode udev \
+ -d "${D}usr/share/iscan-data/epkowa.desc" \
+ -o "${D}${rulesdir}/99-iscan.rules" || die
+ fi
+}
diff --git a/media-gfx/iscan-data/metadata.xml b/media-gfx/iscan-data/metadata.xml
new file mode 100644
index 000000000000..ef34db7e8ac3
--- /dev/null
+++ b/media-gfx/iscan-data/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>mattsch@gmail.com</email>
+ <name>Matthew Schultz</name>
+ </maintainer>
+ <longdescription lang="en">
+ Provides the necessary support files for Image Scan! for Linux,
+ including device information and policy file generation logic.
+ Image Scan! for Linux will not function without this package.
+ </longdescription>
+</pkgmetadata>