summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaterina Vaartis <vaartis@kotobank.ch>2023-05-06 11:33:31 +0300
committerSam James <sam@gentoo.org>2023-05-20 07:27:51 +0100
commit845c7956a21ce66c87f56157214ef03562fc898b (patch)
treec470290b12a8024d73043ff79d81fe6bdbf049c5 /media-gfx/hydrus
parentsys-fs/exfatprogs: add 1.2.1 (diff)
downloadgentoo-845c7956a21ce66c87f56157214ef03562fc898b.tar.gz
gentoo-845c7956a21ce66c87f56157214ef03562fc898b.tar.bz2
gentoo-845c7956a21ce66c87f56157214ef03562fc898b.zip
media-gfx/hydrus: Drop 519
Signed-off-by: Ekaterina Vaartis <vaartis@kotobank.ch> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/hydrus')
-rw-r--r--media-gfx/hydrus/Manifest1
-rw-r--r--media-gfx/hydrus/hydrus-519.ebuild147
2 files changed, 0 insertions, 148 deletions
diff --git a/media-gfx/hydrus/Manifest b/media-gfx/hydrus/Manifest
index b7da688076c7..9071bf023b36 100644
--- a/media-gfx/hydrus/Manifest
+++ b/media-gfx/hydrus/Manifest
@@ -1,2 +1 @@
-DIST hydrus-519.tar.gz 41113296 BLAKE2B 7193fea1d0171af3799a33af68855bd67aa990802e110a3beec4f4f96597e78228e7ad169fce713bd91f862e48d973ca4acef88c204eb3c91f2cebf1d445cb16 SHA512 80abff327a8857d4fe311c4834016b46c45b6889e080675520998cfa196df2c97305368acada570c3a2ebd19caebb2e71c40f6ccd3d17912ad5f19cce09ceac7
DIST hydrus-522.tar.gz 41149565 BLAKE2B 7306f1d275fb6cf4786f012eea8469c58eac8d9ee6392481cd92f791125dec5377f62dceb36005c24102771493e04b00f425579aad95cf5cfdb5310ff7de7c62 SHA512 adcf6c99d579e50248c81ca3016489c15aec8c3763f13634c50ed921b0fe7c974868b082bb2e5d26915ed877bc8df3b70af7e99549bdc177a3e9f46a50cce113
diff --git a/media-gfx/hydrus/hydrus-519.ebuild b/media-gfx/hydrus/hydrus-519.ebuild
deleted file mode 100644
index 57ab39e51e10..000000000000
--- a/media-gfx/hydrus/hydrus-519.ebuild
+++ /dev/null
@@ -1,147 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_REQ_USE="sqlite"
-
-DOCS_BUILDER=mkdocs
-DOCS_DEPEND="dev-python/mkdocs-material dev-python/regex"
-
-inherit python-single-r1 desktop docs optfeature
-
-DESCRIPTION="A booru-like media organizer for the desktop"
-HOMEPAGE="https://hydrusnetwork.github.io/hydrus/ https://github.com/hydrusnetwork/hydrus"
-
-if [[ "${PV}" == "9999" ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/hydrusnetwork/hydrus.git"
-else
- SRC_URI="https://github.com/hydrusnetwork/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
- KEYWORDS="~amd64"
-fi
-
-# hydrus itself is WTFPL
-# icons included are CC-BY-2.5
-LICENSE="WTFPL-2 CC-BY-2.5"
-SLOT="0"
-IUSE="test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RESTRICT="!test? ( test )"
-
-# RDEPEND is sorted as such:
-# - No specific requirements
-# - Specific version or slot
-RDEPEND="
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/cbor2[${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/cloudscraper[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP},lcms]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pyside2[widgets,gui,${PYTHON_USEDEP}]
- dev-python/python-mpv[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/send2trash[${PYTHON_USEDEP}]
- dev-python/service_identity[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/twisted[${PYTHON_USEDEP}]
- media-libs/opencv[python,png,jpeg,${PYTHON_USEDEP}]
- media-video/ffmpeg
-
- >=dev-python/QtPy-1.9.0-r4[pyside2,${PYTHON_USEDEP}]
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- ')
-"
-BDEPEND="
- ${RDEPEND}
- $(python_gen_cond_dep '
- test? (
- dev-python/httmock[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )
- ')
-"
-
-PATCHES=(
- "${FILESDIR}/userpath-in-local-share.patch"
-)
-
-src_prepare() {
- default
-
- # Contains pre-built binaries for other systems and a broken swf renderer for linux
- rm -r bin/ || die
- # Build files used for CI and development, not actually needed
- rm -r static/build_files static/requirements || die
- # Python requirements file, not needed
- rm requirements.txt || die
- # Remove unneeded additional scripts
- rm *.command *.sh *.bat || die
-}
-
-src_compile() {
- python_optimize "${S}"
- docs_compile
-}
-
-src_test() {
- # The tests use unittest, but are run with a custom runner script.
- # QT_QPA_PLATFORM is required to make them run without X
- local -x QT_QPA_PLATFORM=offscreen
- "${EPYTHON}" "${S}/test.py" || die "Tests failed"
-}
-
-src_install() {
- local doc="${EPREFIX}/usr/share/doc/${PF}"
- elog "Hydrus includes an excellent manual, that can either be viewed at"
- elog "${doc}/html/help/index.html"
- elog "or accessed through the hydrus help menu."
-
- mv "help my client will not boot.txt" "help_my_client_will_not_boot.txt" || die
-
- local DOCS=(COPYING README.md help_my_client_will_not_boot.txt db/)
- einstalldocs
-
- # Files only needed for testing
- rm test.py hydrus/hydrus_test.py || die
- rm -r hydrus/test/ static/testing/ || die
-
- # ${DOCS[@]} files are copied into doc
- # ${S}/docs/ is the markdown source code for documentation
- # .gitignore/.github files aren't needed for the program to work, same with mkdocs files
- rm -r "${DOCS[@]}" "${S}/docs/" .gitignore .github/ mkdocs.yml mkdocs-gh-pages.yml || die
- if use doc; then
- # ${S}/_build = ${DOCS_OUTDIR}/.. , these have already been copied, remove before installation
- rm -r "${S}/_build" || die
- # The program expects to find documentation here, so add a symlink to doc
- dosym "${doc}/html" /opt/hydrus/help
- fi
-
- insinto /opt/hydrus
- doins -r "${S}"/.
-
- exeinto /usr/bin
- python_newexe - hydrus-server < <(sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-server" || die)
- python_newexe - hydrus-client < <(sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-client" || die)
-
- make_desktop_entry "hydrus-client" "Hydrus Client" "/opt/hydrus/static/hydrus_non-transparent.png" \
- "AudioVideo;FileTools;Graphics;Network;"
-}
-
-pkg_postinst() {
- optfeature "automatic port forwarding support" "net-libs/miniupnpc"
- optfeature "bandwidth charts support" "dev-python/pyside2[charts]"
- optfeature "memory compression in the client" "dev-python/lz4"
- optfeature "SOCKS proxy support" "dev-python/requests[socks5]" "dev-python/PySocks"
-}