summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-05 21:48:59 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-05 23:26:46 -0700
commit22a01f577f19f686d4c266a550f2a929636365fa (patch)
tree29097b71551464dc34396ec0c1a05ce0d76cf22d /media-gfx/gthumb
parentdev-cpp/highway: Fix detection of AVX512 for IceLake Client CPUs (diff)
downloadgentoo-22a01f577f19f686d4c266a550f2a929636365fa.tar.gz
gentoo-22a01f577f19f686d4c266a550f2a929636365fa.tar.bz2
gentoo-22a01f577f19f686d4c266a550f2a929636365fa.zip
media-gfx/gthumb: Version bump to 3.12.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-gfx/gthumb')
-rw-r--r--media-gfx/gthumb/Manifest1
-rw-r--r--media-gfx/gthumb/files/3.12.2-link-with-x11.patch14
-rw-r--r--media-gfx/gthumb/gthumb-3.12.2.ebuild109
3 files changed, 124 insertions, 0 deletions
diff --git a/media-gfx/gthumb/Manifest b/media-gfx/gthumb/Manifest
index 63f49d31937d..3bf1e8af7a64 100644
--- a/media-gfx/gthumb/Manifest
+++ b/media-gfx/gthumb/Manifest
@@ -1 +1,2 @@
DIST gthumb-3.10.4.tar.xz 7581416 BLAKE2B 7afc94c18d819a5eef7d075489533cf99e7f6d5eaf409b163524a2f62d9c22a40edbc114b16d6d7b7960df53d49cefda9196ebeaa2bc0c19e5760f584628209b SHA512 90f7d83d2fb6db12ef16e5ce29d9310ed5aaccb269004d72df985dda839c1ce738354942f537a23f63cbe724a351a0f13f2eb1e659ada50196af1bc60d5c5d27
+DIST gthumb-3.12.2.tar.xz 7585700 BLAKE2B 9fb4fd934975fb775b82cf17028abd6d4ac3c31ee30458c377d36d3af97e59218e621d09768eebec096c64e3d01697bd3080409fd2191c2af29d84c9b53508c1 SHA512 5304b5cfefa4ced6a244db5a6e2880dad4f5a598654c9ea6c7707ddc0a766bdfa108f827a74e400168dbc338e35db519fffb7ac7382e0ee564771d56af3ac97c
diff --git a/media-gfx/gthumb/files/3.12.2-link-with-x11.patch b/media-gfx/gthumb/files/3.12.2-link-with-x11.patch
new file mode 100644
index 000000000000..b5e84710e5e1
--- /dev/null
+++ b/media-gfx/gthumb/files/3.12.2-link-with-x11.patch
@@ -0,0 +1,14 @@
+https://gitlab.gnome.org/GNOME/gthumb/-/issues/222
+
+diff --git a/meson.build b/meson.build
+index 2a970673..4cdc1a5e 100644
+--- a/meson.build
++++ b/meson.build
+@@ -232,6 +232,7 @@ common_deps = [
+ dependency('gmodule-2.0'),
+ dependency('gio-unix-2.0'),
+ dependency('gtk+-3.0', version : gtk_version),
++ dependency('x11'),
+ dependency('libpng'),
+ dependency('zlib'),
+ dependency('gsettings-desktop-schemas')
diff --git a/media-gfx/gthumb/gthumb-3.12.2.ebuild b/media-gfx/gthumb/gthumb-3.12.2.ebuild
new file mode 100644
index 000000000000..d629fc374ff7
--- /dev/null
+++ b/media-gfx/gthumb/gthumb-3.12.2.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
+
+DESCRIPTION="Image viewer and browser for Gnome"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gthumb"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="cdr colord exif gnome-keyring gstreamer heif http jpegxl lcms raw slideshow svg tiff webp"
+
+# libX11 dep is a workaround. See files/3.12.2-link-with-x11.patch
+RDEPEND="
+ x11-libs/libX11
+
+ >=dev-libs/glib-2.54.0:2
+ >=x11-libs/gtk+-3.16.0:3
+ exif? ( >=media-gfx/exiv2-0.21:= )
+ slideshow? (
+ >=media-libs/clutter-1.12.0:1.0
+ >=media-libs/clutter-gtk-1:1.0
+ )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-plugins/gst-plugins-gtk:1.0
+ )
+ raw? (
+ >=media-libs/libraw-0.14:=
+ <media-libs/libraw-0.21
+ )
+ http? (
+ >=net-libs/libsoup-2.42.0:2.4
+ >=dev-libs/json-glib-0.15.0
+ >=net-libs/webkit-gtk-1.10.0:4
+ )
+ gnome-keyring? ( >=app-crypt/libsecret-0.11 )
+ cdr? ( >=app-cdr/brasero-3.2.0 )
+ svg? ( >=gnome-base/librsvg-2.34:2 )
+ webp? ( >=media-libs/libwebp-0.2.0:= )
+ lcms? ( >=media-libs/lcms-2.6:2 )
+ colord? (
+ >=x11-misc/colord-1.3
+ >=media-libs/lcms-2.6:2
+ )
+
+ sys-libs/zlib
+ virtual/jpeg:0=
+ tiff? ( media-libs/tiff:= )
+ media-libs/libpng:0=
+ >=gnome-base/gsettings-desktop-schemas-0.1.4
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/appstream-0.14.6
+ dev-util/glib-utils
+ dev-util/itstool
+ sys-devel/bison
+ sys-devel/flex
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-link-with-x11.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Drun-in-place=false
+ $(meson_use exif exiv2)
+ $(meson_use slideshow clutter)
+ $(meson_use gstreamer)
+ -Dlibchamplain=false # Upstream still doesn't seem to consider this ready
+ $(meson_use colord)
+ $(meson_use tiff libtiff)
+ $(meson_use webp libwebp)
+ $(meson_use jpegxl libjxl)
+ $(meson_use heif libheif)
+ $(meson_use raw libraw)
+ $(meson_use svg librsvg)
+ $(meson_use gnome-keyring libsecret)
+ $(meson_use http webservices)
+ $(meson_use cdr libbrasero)
+ )
+
+ # colord pulls in lcms2 anyway, so enable lcms with USE="colord -lcms"; some of upstream HAVE_COLORD code depends on HAVE_LCMS2
+ if use lcms || use colord; then
+ emesonargs+=( -Dlcms2=true )
+ else
+ emesonargs+=( -Dlcms2=false )
+ fi
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}