summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2024-08-20 00:17:29 +0300
committerJoonas Niilola <juippis@gentoo.org>2024-08-30 15:05:09 +0300
commit3fe5313bcd3fccd8f16874a10560ce10351b1a10 (patch)
tree3f0196ae1068e9f2b339bbd78a7ba60591d41b52 /media-gfx/gimp
parentapp-admin/cronolog: drop 1.6.2-r6 (diff)
downloadgentoo-3fe5313bcd3fccd8f16874a10560ce10351b1a10.tar.gz
gentoo-3fe5313bcd3fccd8f16874a10560ce10351b1a10.tar.bz2
gentoo-3fe5313bcd3fccd8f16874a10560ce10351b1a10.zip
media-gfx/gimp: -9999, make python plug-ins mandatory (rm USE=python)
Closes: https://bugs.gentoo.org/937801 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/38211 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx/gimp')
-rw-r--r--media-gfx/gimp/gimp-9999.ebuild30
1 files changed, 13 insertions, 17 deletions
diff --git a/media-gfx/gimp/gimp-9999.ebuild b/media-gfx/gimp/gimp-9999.ebuild
index 122443176973..477c892d26a4 100644
--- a/media-gfx/gimp/gimp-9999.ebuild
+++ b/media-gfx/gimp/gimp-9999.ebuild
@@ -15,10 +15,10 @@ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/gimp.git"
LICENSE="GPL-3+ LGPL-3+"
SLOT="0/3"
-IUSE="X aalib alsa doc gnome heif javascript jpeg2k jpegxl lua mng openexr openmp postscript python test udev unwind vala vector-icons webp wmf xpm"
+IUSE="X aalib alsa doc gnome heif javascript jpeg2k jpegxl lua mng openexr openmp postscript test udev unwind vala vector-icons webp wmf xpm"
REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
lua? ( ${LUA_REQUIRED_USE} )
- python? ( ${PYTHON_REQUIRED_USE} )
"
RESTRICT="!test? ( test )"
@@ -26,6 +26,10 @@ RESTRICT="!test? ( test )"
# media-libs/{babl,gegl} are required to be built with USE="introspection"
# to fix the compilation checking of /usr/share/gir-1.0/{Babl-0.1gir,Gegl-0.4.gir}
COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.0:3[${PYTHON_USEDEP}]
+ ')
>=app-accessibility/at-spi2-core-2.46.0
>=app-text/poppler-0.90.1[cairo]
>=app-text/poppler-data-0.4.9
@@ -36,10 +40,10 @@ COMMON_DEPEND="
dev-libs/libxslt
>=gnome-base/librsvg-2.40.21:2
>=media-gfx/mypaint-brushes-2.0.2:=
- >=media-libs/babl-0.1.98[introspection,lcms,vala?]
+ >=media-libs/babl-9999[introspection,lcms,vala?]
>=media-libs/fontconfig-2.12.6
>=media-libs/freetype-2.10.2
- >=media-libs/gegl-0.4.48:0.4[cairo,introspection,lcms,vala?]
+ >=media-libs/gegl-9999[cairo,introspection,lcms,vala?]
>=media-libs/gexiv2-0.14.0
>=media-libs/harfbuzz-2.6.5:=
>=media-libs/lcms-2.13.1:2
@@ -69,12 +73,6 @@ COMMON_DEPEND="
mng? ( media-libs/libmng:= )
openexr? ( >=media-libs/openexr-2.3.0:= )
postscript? ( app-text/ghostscript-gpl:= )
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- >=dev-python/pygobject-3.0:3[${PYTHON_USEDEP}]
- ')
- )
udev? ( >=dev-libs/libgudev-167:= )
unwind? ( >=sys-libs/libunwind-1.1.0:= )
webp? ( >=media-libs/libwebp-0.6.0:= )
@@ -116,11 +114,12 @@ pkg_pretend() {
pkg_setup() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-
+ python-single-r1_pkg_setup
use lua && lua-single_pkg_setup
- if use python; then
- python-single-r1_pkg_setup
+ if has_version ">=media-libs/babl-9999" || has_version ">=media-libs/gegl-9999"; then
+ ewarn "Please make sure to rebuid media-libs/babl-9999 and media-libs/gegl-9999 packages"
+ ewarn "before building media-gfx/gimp-9999 to have their latest master branch versions."
fi
}
@@ -182,7 +181,6 @@ src_configure() {
$(meson_feature openexr)
$(meson_feature openmp)
$(meson_feature postscript ghostscript)
- $(meson_feature python)
$(meson_feature test headless-tests)
$(meson_feature udev gudev)
$(meson_feature vala)
@@ -229,9 +227,7 @@ src_test() {
src_install() {
meson_src_install
- if use python; then
- python_optimize
- fi
+ python_optimize
# Workaround for bug #321111 to give GIMP the least
# precedence on PDF documents by default