summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-01-16 12:13:51 +0100
committerSam James <sam@gentoo.org>2022-01-28 08:24:01 +0000
commitc0d511652d855d453231c9e301c1516586889131 (patch)
tree4e2db27fb3dc97fa088699750c43f0bb34b9d5a1 /media-gfx/freecad
parentdev-util/gef: add proxied attribute (diff)
downloadgentoo-c0d511652d855d453231c9e301c1516586889131.tar.gz
gentoo-c0d511652d855d453231c9e301c1516586889131.tar.bz2
gentoo-c0d511652d855d453231c9e301c1516586889131.zip
media-gfx/freecad: fix patchset
Split the patchset and use several patches instead of a compressed patch set stored elsewhere. This way, the patches can be handled more easily in case of upstream changes to some of the files. Some of the source code files have to be patched in order to use the settings. Bug: https://github.com/waebbl/waebbl-gentoo/issues/354 Bug: https://github.com/waebbl/waebbl-gentoo/issues/355 Closes: https://bugs.gentoo.org/831086 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/23825 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/freecad')
-rw-r--r--media-gfx/freecad/Manifest1
-rw-r--r--media-gfx/freecad/freecad-9999.ebuild30
2 files changed, 11 insertions, 20 deletions
diff --git a/media-gfx/freecad/Manifest b/media-gfx/freecad/Manifest
index cf58ec9ff504..fe0489b287e6 100644
--- a/media-gfx/freecad/Manifest
+++ b/media-gfx/freecad/Manifest
@@ -1,3 +1,2 @@
DIST freecad-0.19.2-0005-Make-smesh-compile-with-vtk9.patch.xz 5368 BLAKE2B 69bafefd049effe3c31719bb2c23d32e8ba7ad58235c58ac8279ba6c036feaf1b97d5751cf2d68896e7489803103b2d0f92f76e61b3ccc97ef05a95b337ca5c2 SHA512 66585cc13fb3b0b026cf9dbd761c8ba1c1fe4d4f7db2e144ddd97706e02ccd78f4a43ac7cd93ddcae6e73933bf41d4cbd4d94bcdff8804b81378a6d946c7b070
DIST freecad-0.19.2.tar.gz 296987961 BLAKE2B 3c21359c71f7ac5a49cc4b4be437dfce02f2af73dfc526a3955547718ee41c461fc787d029a9a77374d58516d7c56fec6982fe6d38ab17fbc30c0a94929136bf SHA512 420f00e696725cbd31c936c47b6ac226d866a17c7b7683ad381b8dd5edaffc7dfb1a3c4238c08e8b4fd34ef0c08d7c244cb7797012e596df1ce0a4f6e3be6b72
-DIST freecad-9999-Gentoo-specific-fix-install-locations-of-Ext-and-Mod.patch.xz 4144 BLAKE2B bfd9a0fcd9a6a5fb4c9ef2d5e88e69b869f908142cedf5dd1449b917d90e36187ce6227af99613efedd05eb3218d17e9e6df4430ea0413988340c91c111bbe4e SHA512 5d452eca6bc88fb50ae47a6b6127e39f3d17a60498627920b13273e6afaceaca64e47ade4d1fce18b3bfbcdf4eb13565244ecc575707f1aedf3bb1d6dfc7e89e
diff --git a/media-gfx/freecad/freecad-9999.ebuild b/media-gfx/freecad/freecad-9999.ebuild
index 2852f295c8e1..97ada209ae61 100644
--- a/media-gfx/freecad/freecad-9999.ebuild
+++ b/media-gfx/freecad/freecad-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,12 +11,10 @@ DESCRIPTION="QT based Computer Aided Design application"
HOMEPAGE="https://www.freecadweb.org/ https://github.com/FreeCAD/FreeCAD"
MY_PN=FreeCAD
-MY_PATCH="${P}-Gentoo-specific-fix-install-locations-of-Ext-and-Mod"
if [[ ${PV} = *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/${MY_PN}/${MY_PN}.git"
- SRC_URI="https://raw.githubusercontent.com/waebbl/waebbl-gentoo/master/patches/${MY_PATCH}.patch.xz"
S="${WORKDIR}/freecad-${PV}"
else
MY_PV=$(ver_cut 1-2)
@@ -139,11 +137,6 @@ pkg_setup() {
[[ -z ${CASROOT} ]] && die "\${CASROOT} not set, plesae run eselect opencascade"
}
-src_unpack() {
- git-r3_src_unpack
- unpack ${MY_PATCH}.patch.xz
-}
-
src_prepare() {
# the upstream provided file doesn't find the coin doc tag file,
# but cmake ships a working one, so we use this.
@@ -153,13 +146,6 @@ src_prepare() {
sed -e 's/Exec=FreeCAD/Exec=freecad/' -i src/XDGData/org.freecadweb.FreeCAD.desktop || die
cmake_src_prepare
-
- # Fix line endings on a few files for patching
- for f in src/Mod/{Cloud,Inspection,Start/StartPage}/CMakeLists.txt; do
- dos2unix -q ${f}
- done
-
- eapply "${WORKDIR}"/${P}-Gentoo-specific-fix-install-locations-of-Ext-and-Mod.patch
}
src_configure() {
@@ -210,10 +196,10 @@ src_configure() {
-DBUILD_WEB=ON # needed by start workspace
-DBUILD_WITH_CONDA=OFF
- -DCMAKE_INSTALL_DATADIR=share/${PN}/data
- -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
- -DCMAKE_INSTALL_INCLUDEDIR=include/${PN}
- -DCMAKE_INSTALL_LIBDIR=$(get_libdir)/${PN}
+ -DCMAKE_INSTALL_DATADIR=/usr/share/${PN}/data
+ -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+ -DCMAKE_INSTALL_INCLUDEDIR=/usr/include/${PN}
+ -DCMAKE_INSTALL_PREFIX=/usr/$(get_libdir)/${PN}
-DFREECAD_BUILD_DEBIAN=OFF
@@ -275,6 +261,12 @@ src_install() {
dobin src/Tools/freecad-thumbnailer
+ if ! use headless; then
+ dosym -r /usr/$(get_libdir)/${PN}/bin/FreeCAD /usr/bin/freecad
+ mv "${ED}"/usr/$(get_libdir)/${PN}/share/* "${ED}"/usr/share || die "failed to move shared resources"
+ fi
+ dosym -r /usr/$(get_libdir)/${PN}/bin/FreeCADCmd /usr/bin/freecadcmd
+
python_optimize "${ED}"/usr/share/${PN}/data/Mod/Start/StartPage "${ED}"/usr/$(get_libdir)/${PN}{/Ext,/Mod}/
# compile main package in python site-packages as well
python_optimize