summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-01-08 00:47:03 -0300
committerMatt Turner <mattst88@gentoo.org>2023-01-08 12:56:11 -0500
commit44d429fc9a495ccca5ba36f3bf6646277fdd18d2 (patch)
treed07a4057898eb5feb2050fcd47b07e85a06566a4 /media-gfx/eog-plugins
parentmedia-gfx/eog: Version bump to 43.2 (diff)
downloadgentoo-44d429fc9a495ccca5ba36f3bf6646277fdd18d2.tar.gz
gentoo-44d429fc9a495ccca5ba36f3bf6646277fdd18d2.tar.bz2
gentoo-44d429fc9a495ccca5ba36f3bf6646277fdd18d2.zip
media-gfx/eog-plugins: Version bump to 42.3
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29007 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-gfx/eog-plugins')
-rw-r--r--media-gfx/eog-plugins/Manifest1
-rw-r--r--media-gfx/eog-plugins/eog-plugins-42.3.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
index c79073580ddc..4235b4600f5d 100644
--- a/media-gfx/eog-plugins/Manifest
+++ b/media-gfx/eog-plugins/Manifest
@@ -1 +1,2 @@
DIST eog-plugins-42.2.tar.xz 131708 BLAKE2B 7df06ca7d4d10e068b6d758ec3c29fe8cb7a2037755bab55536f1cd3581790f7a1288a9530f256df3d2adbf6d7f8c893907fa962be8adb77510cab8e9684298c SHA512 7508231c1a6b365acfedd73b37911d5ac4194e6b5c4f5d80be27529ec749774d61ddc75288f8678d879f0cc2d9117a5f725092efe30403b5b3e145c77fa3030d
+DIST eog-plugins-42.3.tar.xz 134284 BLAKE2B 903ee1af89d48c46ab12d1330b4605cd78db573d59d5fc6ba34c27a8b017ce90c2af0b55009e5ecec61229dbdd8852bc4ecc5b10e6a2d2391c06e8244f7b24da SHA512 af680fe7cc83d3b3ae6782127edf90cf2a89093030f15d22fe5ff81eb165a493dc487b32a41383c36b72ce188c8f49b3f52ca3b991d24faa9667b0317bff414f
diff --git a/media-gfx/eog-plugins/eog-plugins-42.3.ebuild b/media-gfx/eog-plugins/eog-plugins-42.3.ebuild
new file mode 100644
index 000000000000..2a3f26227dfd
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-42.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome.org meson python-single-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins https://gitlab.gnome.org/GNOME/eog-plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif map picasa +python test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.53.4:2
+ >=dev-libs/libpeas-1.14.1:=
+ >=media-gfx/eog-41.0
+ exif? ( >=media-libs/libexif-0.6.16 )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0
+ )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/glib[dbus]
+ dev-libs/libpeas:=[gtk,python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/appstream-glib )"
+BDEPEND="
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use exif plugin_exif-display)
+ $(meson_use python plugin_export-to-folder)
+ -Dplugin_fit-to-width=true
+ $(meson_use python plugin_fullscreenbg)
+ -Dplugin_light-theme=true
+ $(meson_use map plugin_map)
+ $(meson_use python plugin_maximize-windows)
+ $(meson_use picasa plugin_postasa)
+ -Dplugin_postr=false
+ $(meson_use python plugin_pythonconsole)
+ -Dplugin_send-by-mail=true
+ $(meson_use python plugin_slideshowshuffle)
+ )
+ meson_src_configure
+}