summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/crwinfo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/crwinfo')
-rw-r--r--media-gfx/crwinfo/Manifest1
-rw-r--r--media-gfx/crwinfo/crwinfo-0.2.ebuild31
-rw-r--r--media-gfx/crwinfo/files/crwinfo-0.2.patch17
-rw-r--r--media-gfx/crwinfo/metadata.xml15
4 files changed, 64 insertions, 0 deletions
diff --git a/media-gfx/crwinfo/Manifest b/media-gfx/crwinfo/Manifest
new file mode 100644
index 000000000000..21fd48b974db
--- /dev/null
+++ b/media-gfx/crwinfo/Manifest
@@ -0,0 +1 @@
+DIST CRWInfo-0.2.tar.gz 10717 SHA256 a7b0572e96cfa895d2ca04c10618514f7c86c038332d900dcf5715463c851478
diff --git a/media-gfx/crwinfo/crwinfo-0.2.ebuild b/media-gfx/crwinfo/crwinfo-0.2.ebuild
new file mode 100644
index 000000000000..a70c54a3af57
--- /dev/null
+++ b/media-gfx/crwinfo/crwinfo-0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Canon raw image (CRW) information and thumbnail extractor"
+HOMEPAGE="http://freshmeat.net/projects/crwinfo/"
+SRC_URI="http://neuemuenze.heim1.tu-clausthal.de/~sven/crwinfo/CRWInfo-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc amd64 alpha ia64 hppa ppc64"
+IUSE=""
+
+S="${WORKDIR}/CRWInfo-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}.patch
+ sed \
+ -e '/gcc/s:^.*$:\t$(CC) $(CFLAGS) -Wall -c crwinfo.c\n\t$(CC) $(LDFLAGS) -o crwinfo crwinfo.o:g' \
+ -i Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ dobin crwinfo
+ dodoc README spec
+}
diff --git a/media-gfx/crwinfo/files/crwinfo-0.2.patch b/media-gfx/crwinfo/files/crwinfo-0.2.patch
new file mode 100644
index 000000000000..18170b10d71e
--- /dev/null
+++ b/media-gfx/crwinfo/files/crwinfo-0.2.patch
@@ -0,0 +1,17 @@
+--- crwinfo.c.orig 2002-07-30 11:17:03.000000000 -0600
++++ crwinfo.c 2005-01-21 15:24:54.256888228 -0700
+@@ -95,10 +95,10 @@
+ fprintf( stderr, "-m show misc. information (whitepoint, AF mode etc)\n" );
+ fprintf( stderr, "-f show flash information (flash mode etc)\n" );
+ fprintf( stderr, "-cf show custom function settings\n" );
+- fprintf( stderr, "-t extract the thumbnail to the optional filename.
+- If no filename for the thumbnail is given, the
+- name of the CRW-file is used with a .jpg
+- extension\n" );
++ fprintf( stderr, "-t extract the thumbnail to the optional filename. \n" );
++ fprintf( stderr, " If no filename for the thumbnail is given, the\n" );
++ fprintf( stderr, " name of the CRW-file is used with a .jpg\n" );
++ fprintf( stderr, " extension\n" );
+ fprintf( stderr, "-x show experimental information (don't rely on it)\n" );
+ exit(0);
+ }
diff --git a/media-gfx/crwinfo/metadata.xml b/media-gfx/crwinfo/metadata.xml
new file mode 100644
index 000000000000..63d348245aec
--- /dev/null
+++ b/media-gfx/crwinfo/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+ <longdescription lang="en">
+ Utility to extract thumbnails and information from Canon raw (CRW)
+ files.
+ </longdescription>
+ <upstream>
+ <remote-id type="freshmeat">crwinfo</remote-id>
+ </upstream>
+</pkgmetadata>