summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-11-24 07:56:04 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-11-24 07:56:04 +0100
commitec7530947213bf795945c74b6ccb698d346b498c (patch)
tree7cd74cf51b745e80f76bf19681a201f9df0fe2ab /media-gfx/chafa
parentmedia-gfx/chafa: drop 1.10.3 (diff)
downloadgentoo-ec7530947213bf795945c74b6ccb698d346b498c.tar.gz
gentoo-ec7530947213bf795945c74b6ccb698d346b498c.tar.bz2
gentoo-ec7530947213bf795945c74b6ccb698d346b498c.zip
media-gfx/chafa: add 1.12.4
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'media-gfx/chafa')
-rw-r--r--media-gfx/chafa/Manifest1
-rw-r--r--media-gfx/chafa/chafa-1.12.4.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-gfx/chafa/Manifest b/media-gfx/chafa/Manifest
index 40e12fad776b..af59cdfe0ad9 100644
--- a/media-gfx/chafa/Manifest
+++ b/media-gfx/chafa/Manifest
@@ -1 +1,2 @@
DIST chafa-1.12.3.tar.xz 659136 BLAKE2B 2b9878b93c46be37fc7cfaf9ffadf58a84445b2e081c712a9824f323b0aee5725fd0b229a0a073afd0a7e3354d418669c411e02ac0f98a4e2eeaff9c19f6f93c SHA512 00d186aa3e5a184b5fe985909118fe856c7889e6674d55de6fe409f04ccac0a8698ef8063a2049e8b100ea0e9abfa5f89c959333a18cd6f934608b86f256ee5d
+DIST chafa-1.12.4.tar.xz 934272 BLAKE2B 57009e5b6c8cbb41643e94d224e9a4a7e3c2839ee79a6d4949b6d872ab9e10ab66fe7a609f448cad68ee930e5da84e31a1368c8f7ad6457c4c1583971f87f91e SHA512 2732ff380fc6d61124298ae3d9958d676fe6ca2887ee11df057d4efa6f4ae9c074a7e1920a6a3db1ffb21882432769967f4453d52a0344e581993984133a0e9b
diff --git a/media-gfx/chafa/chafa-1.12.4.ebuild b/media-gfx/chafa/chafa-1.12.4.ebuild
new file mode 100644
index 000000000000..9a2b941734b1
--- /dev/null
+++ b/media-gfx/chafa/chafa-1.12.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="versatile and fast Unicode/ASCII/ANSI graphics renderer"
+HOMEPAGE="https://hpjansson.org/chafa/ https://github.com/hpjansson/chafa"
+SRC_URI="https://hpjansson.org/chafa/releases/${P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="+tools"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-gfx/imagemagick:0=
+ tools? ( >=media-libs/freetype-2.0.0 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-man \
+ $(use_with tools)
+}
+
+src_install() {
+ local DOCS=( AUTHORS NEWS README TODO )
+ default
+
+ use tools && doman docs/chafa.1
+
+ find "${ED}" -name '*.la' -delete || die
+}