summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/aewan
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/aewan')
-rw-r--r--media-gfx/aewan/Manifest1
-rw-r--r--media-gfx/aewan/aewan-1.0.01-r1.ebuild29
-rw-r--r--media-gfx/aewan/files/aewan-1.0.01-debug_aewl-warnings.patch10
-rw-r--r--media-gfx/aewan/files/aewan-1.0.01-tinfo.patch15
-rw-r--r--media-gfx/aewan/metadata.xml20
5 files changed, 75 insertions, 0 deletions
diff --git a/media-gfx/aewan/Manifest b/media-gfx/aewan/Manifest
new file mode 100644
index 000000000000..6788e0cc9f94
--- /dev/null
+++ b/media-gfx/aewan/Manifest
@@ -0,0 +1 @@
+DIST aewan-1.0.01.tar.gz 122880 SHA256 5266dec5e185e530b792522821c97dfa5f9e3892d0dca5e881d0c30ceac21817 SHA512 8c7e81ed3e2c4d0848e36ed60922c920471c7bc46a7127f529be3f5a9c3c66a6e0dff06bca7b5cb21eb0a93d03ba31fd4ef07fc48e2e39f2224956801fe322f3 WHIRLPOOL d432ad982507324a2467bc88b6158d1365e6d2abd50eacf52814ed9d16c5569f1e59cf08c9cd2f14ed80381c1e9fa71c1451145daf8f92677e9af235d3e12880
diff --git a/media-gfx/aewan/aewan-1.0.01-r1.ebuild b/media-gfx/aewan/aewan-1.0.01-r1.ebuild
new file mode 100644
index 000000000000..7fdd8084cb70
--- /dev/null
+++ b/media-gfx/aewan/aewan-1.0.01-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A curses-based ascii-art editor"
+HOMEPAGE="http://aewan.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DOCS=( CHANGELOG README TODO )
+
+DEPEND="sys-libs/zlib
+ >=sys-libs/ncurses-5.0"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-debug_aewl-warnings.patch" \
+ "${FILESDIR}/${P}-tinfo.patch"
+ eautoreconf
+}
diff --git a/media-gfx/aewan/files/aewan-1.0.01-debug_aewl-warnings.patch b/media-gfx/aewan/files/aewan-1.0.01-debug_aewl-warnings.patch
new file mode 100644
index 000000000000..4d96f487741f
--- /dev/null
+++ b/media-gfx/aewan/files/aewan-1.0.01-debug_aewl-warnings.patch
@@ -0,0 +1,10 @@
+--- aewan-1.0.01.orig/debug_aewl.c
++++ aewan-1.0.01/debug_aewl.c
+@@ -8,6 +8,7 @@
+ #include "aewl/label.h"
+
+ #include "keys.h"
++#include "filedlg.h"
+
+ #include <ncurses.h>
+ #include <stdbool.h>
diff --git a/media-gfx/aewan/files/aewan-1.0.01-tinfo.patch b/media-gfx/aewan/files/aewan-1.0.01-tinfo.patch
new file mode 100644
index 000000000000..b4edfd1b990c
--- /dev/null
+++ b/media-gfx/aewan/files/aewan-1.0.01-tinfo.patch
@@ -0,0 +1,15 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -13,9 +13,10 @@
+
+ # Checks for libraries.
+ AC_CHECK_LIB([ncurses], [initscr], [],
+- AC_MSG_ERROR([Can't find ncurses library. Install it first.]))
++ AC_MSG_ERROR([Cannot find ncurses library. Install it first.]))
++AC_SEARCH_LIBS([define_key], [tinfo])
+ AC_CHECK_LIB([z], [gzopen], [],
+- AC_MSG_ERROR([Can't find zlib library. Install it first.]))
++ AC_MSG_ERROR([Cannot find zlib library. Install it first.]))
+
+ # Checks for header files.
+ AC_HEADER_STDC
diff --git a/media-gfx/aewan/metadata.xml b/media-gfx/aewan/metadata.xml
new file mode 100644
index 000000000000..39ec7931c103
--- /dev/null
+++ b/media-gfx/aewan/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zlogene@gentoo.org</email>
+ <name>Mikle Kolyada</name>
+ </maintainer>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <longdescription lang="en">
+Aewan is a multi-layered ascii-art/animation editor that produces both
+stand-alone cat-able art files and an easy-to-parse format for integration in
+your terminal applications.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">aewan</remote-id>
+ </upstream>
+</pkgmetadata>