summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2023-12-18 02:43:07 +0000
committerSam James <sam@gentoo.org>2023-12-21 11:49:44 +0000
commit82d46adc2261c13e2dea5b1bcc43b032b8104eee (patch)
tree1adce07658f1d5b2e7358d5f4097e6733c9de163 /mate-extra
parentmate-extra/mate-user-share: add 1.27.0 (diff)
downloadgentoo-82d46adc2261c13e2dea5b1bcc43b032b8104eee.tar.gz
gentoo-82d46adc2261c13e2dea5b1bcc43b032b8104eee.tar.bz2
gentoo-82d46adc2261c13e2dea5b1bcc43b032b8104eee.zip
mate-extra/mate-utils: add 1.26.1, 1.27.0
1.27.0 seems to fix #917395 however more testing and upstream reporting is required to close. https://bugs.gentoo.org/917395 Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/mate-utils/Manifest2
-rw-r--r--mate-extra/mate-utils/mate-utils-1.26.1.ebuild74
-rw-r--r--mate-extra/mate-utils/mate-utils-1.27.0.ebuild74
3 files changed, 150 insertions, 0 deletions
diff --git a/mate-extra/mate-utils/Manifest b/mate-extra/mate-utils/Manifest
index 8c40c28018bf..922c88bfeb55 100644
--- a/mate-extra/mate-utils/Manifest
+++ b/mate-extra/mate-utils/Manifest
@@ -1 +1,3 @@
DIST mate-utils-1.26.0.tar.xz 7984892 BLAKE2B 9785ecc232f06241bfc389550226d0a099a543c91b9c131e1f2b8998dccd4152c4c056070b10dcd3b98f4d59be87304b999998a10192257aaa682834f6d544e5 SHA512 c8752f6b43a836adc647ec8a9eef4fcea782914994d27ee8491406188da584aa98244d0ba402005beecc293d1b6e50a9ed5339467011e05f301a6b98c2374b91
+DIST mate-utils-1.26.1.tar.xz 8022244 BLAKE2B 73bcaae2fae9c9eafa8a9236d6ce73b46f7d013bad02dd6a9925acd4a698277b20044d45a884108bbdd71093589c090a8293e52e354de0a1c167f71845b2d10c SHA512 b8ec7b510ff872a0427e074ee09824e90ad62fe76ab1dac038ecbe86fd361b15acf57769e58df2c8c9c6acb57d9f1cd0718d178a2a2d1262de1476956d446dd3
+DIST mate-utils-1.27.0.tar.xz 8013804 BLAKE2B e195b65500cab6d155dbd8689518631db1d5705170e8c756e7b43c757d5bff119165ee206aee6fde4801db0b59b2cfb569d7a644a74b17a917c690db2ee49db4 SHA512 97edee5d13f7c88ef38bf4f0836ed7326ff6d0db946bf6879a4a0827f36d60eebea7e5f4ade5f53b611fb2dc94b3885626a84fc0132ce77ed3c43a901eb9d861
diff --git a/mate-extra/mate-utils/mate-utils-1.26.1.ebuild b/mate-extra/mate-utils/mate-utils-1.26.1.ebuild
new file mode 100644
index 000000000000..5bf1ea023b45
--- /dev/null
+++ b/mate-extra/mate-utils/mate-utils-1.26.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="Utilities for the MATE desktop"
+LICENSE="FDL-1.1+ GPL-2+ GPL-3+ LGPL-2+"
+SLOT="0"
+
+IUSE="X applet debug ipv6 nls test udisks"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0
+ >=dev-libs/glib-2.50:2
+ >=gnome-base/libgtop-2.12:2=
+ >=media-libs/libcanberra-0.4[gtk3]
+ sys-libs/zlib
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/pango
+ applet? ( >=mate-base/mate-panel-1.17.0 )
+ udisks? ( >=sys-fs/udisks-1.90.0:2 )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ mate-base/mate-desktop
+ virtual/libintl
+"
+
+BDEPEND="${COMMON_DEPEND}
+ app-text/rarian
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools
+ dev-libs/libxml2
+ dev-util/glib-utils
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+
+src_prepare() {
+ # Make apps visible in all DEs.
+ LC_ALL=C find . -iname '*.desktop.in*' -exec \
+ sed -e '/OnlyShowIn/d' -i {} + || die
+
+ mate_src_prepare
+}
+
+src_configure() {
+ mate_src_configure \
+ --enable-zlib \
+ --enable-debug=$(usex debug yes minimum) \
+ $(use_with X x) \
+ $(use_enable applet gdict-applet) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable udisks disk_image_mounter)
+}
diff --git a/mate-extra/mate-utils/mate-utils-1.27.0.ebuild b/mate-extra/mate-utils/mate-utils-1.27.0.ebuild
new file mode 100644
index 000000000000..5bf1ea023b45
--- /dev/null
+++ b/mate-extra/mate-utils/mate-utils-1.27.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="Utilities for the MATE desktop"
+LICENSE="FDL-1.1+ GPL-2+ GPL-3+ LGPL-2+"
+SLOT="0"
+
+IUSE="X applet debug ipv6 nls test udisks"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0
+ >=dev-libs/glib-2.50:2
+ >=gnome-base/libgtop-2.12:2=
+ >=media-libs/libcanberra-0.4[gtk3]
+ sys-libs/zlib
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/pango
+ applet? ( >=mate-base/mate-panel-1.17.0 )
+ udisks? ( >=sys-fs/udisks-1.90.0:2 )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ mate-base/mate-desktop
+ virtual/libintl
+"
+
+BDEPEND="${COMMON_DEPEND}
+ app-text/rarian
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools
+ dev-libs/libxml2
+ dev-util/glib-utils
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+
+src_prepare() {
+ # Make apps visible in all DEs.
+ LC_ALL=C find . -iname '*.desktop.in*' -exec \
+ sed -e '/OnlyShowIn/d' -i {} + || die
+
+ mate_src_prepare
+}
+
+src_configure() {
+ mate_src_configure \
+ --enable-zlib \
+ --enable-debug=$(usex debug yes minimum) \
+ $(use_with X x) \
+ $(use_enable applet gdict-applet) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable udisks disk_image_mounter)
+}