summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-12-16 21:35:07 +0000
committerMarek Szuba <marecki@gentoo.org>2023-12-16 21:39:01 +0000
commitd6bed80336cae2f09210cb524354acdd8603d3db (patch)
tree496cbe6e6f481cc1dc69f5a2d52df281ce164515 /mail-mta/proton-mail-bridge
parentmedia-video/mpv: Apply upstream patch to fix USE="drm -wayland -X" (diff)
downloadgentoo-d6bed80336cae2f09210cb524354acdd8603d3db.tar.gz
gentoo-d6bed80336cae2f09210cb524354acdd8603d3db.tar.bz2
gentoo-d6bed80336cae2f09210cb524354acdd8603d3db.zip
mail-mta/proton-mail-bridge: add 3.6.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'mail-mta/proton-mail-bridge')
-rw-r--r--mail-mta/proton-mail-bridge/Manifest2
-rw-r--r--mail-mta/proton-mail-bridge/proton-mail-bridge-3.6.1.ebuild119
2 files changed, 121 insertions, 0 deletions
diff --git a/mail-mta/proton-mail-bridge/Manifest b/mail-mta/proton-mail-bridge/Manifest
index 3b3c92a21275..b71490e18859 100644
--- a/mail-mta/proton-mail-bridge/Manifest
+++ b/mail-mta/proton-mail-bridge/Manifest
@@ -4,3 +4,5 @@ DIST proton-mail-bridge-3.3.2-deps.tar.xz 252980292 BLAKE2B 2d7c8961c1ed8a6fb15a
DIST proton-mail-bridge-3.3.2.tar.gz 4481491 BLAKE2B e00cf4268dcebc7f4eeab5a0738c04e1a809a5633b4d97637ea74aa4ac3eb68dd343b45fef5fca602c4c89faa2d1e05f1c605d9b56ee83d669b07b815f8ae92b SHA512 1b49355f8e816b6a00bf7fad91d0f696efb5ee1f5ea311fd4b92549f715185ea280ac874a759be5d3f8c7ff2309b8f0c3bb37c8502963059b26f4630bc9339f0
DIST proton-mail-bridge-3.5.4-deps.tar.xz 246550932 BLAKE2B 6b83a8c331e70abf026d2b74c85e5e52360f4163e23bb25b8cdf25558125e675805a2850eb43d40bf02f1109204f9f5d002e0862fd9b956b88b7078c7fdd1cd0 SHA512 a5ba16e77c6d773361223fc661959d38870b47f79ff303d0940305bdbe7a3ad8444ed47e166a13e13ca52010c1153b681728870d2cec7941bdd9185f47a2d4e2
DIST proton-mail-bridge-3.5.4.tar.gz 4428659 BLAKE2B b366ee551279a46c928cba33b8879c12a101caae24a73d8aa6110cc2269dc94a9c7208c0e6a9c25485494a886e226d446aed29b76b8a95e4229d0a0e67bcf814 SHA512 7fc82ef135da5c24607cfca14d08aafdf4e7de51b087b279dbfb42c0a363db4bfb8ed029dc598fd30ffdb298798cebc1530338c87be28e495ee7e18c24e7558d
+DIST proton-mail-bridge-3.6.1-deps.tar.xz 245805016 BLAKE2B 7aeab4896c9dfcba8c2c3164f441fb57f0febbdc0c49f7555cda3d930443efec85d8748a43ed2ed23982594c6f5e4b8e319cd2524bfa21797a8259252397f5a9 SHA512 46a5601606fe99af0ffcc8ba1e325d17b527d15225f6f4c339de0f828e0a17e71304886a58ccf2dde83638e83bc87abb7ef9817db44014cc38132dc65d752fdf
+DIST proton-mail-bridge-3.6.1.tar.gz 5015293 BLAKE2B 7a6bb687fd1130612a49d4336404229daece91a24a37952b3128462b81cfe83636b935d584b479d294037d0303406f2c79a6798725d7b62f55eefa9294047ba9 SHA512 39e11815cdfdcd741ba04ee6776ce4bd959715d8d5bb8345b7f7b1a66b5fa5b66890ebc0353b1f5566a822e0ad1c4757fd022b67f4c66e91113b5e700db04abd
diff --git a/mail-mta/proton-mail-bridge/proton-mail-bridge-3.6.1.ebuild b/mail-mta/proton-mail-bridge/proton-mail-bridge-3.6.1.ebuild
new file mode 100644
index 000000000000..d64b250bc9c0
--- /dev/null
+++ b/mail-mta/proton-mail-bridge/proton-mail-bridge-3.6.1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake go-module systemd xdg-utils
+
+MY_PN="${PN/-mail/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Serves ProtonMail to IMAP/SMTP clients"
+HOMEPAGE="https://proton.me/mail/bridge https://github.com/ProtonMail/proton-bridge/"
+SRC_URI="https://github.com/ProtonMail/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~marecki/dists/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 GPL-3+ ISC LGPL-3+ MIT MPL-2.0 Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gui"
+
+# Quite a few tests require Internet access
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="app-crypt/libsecret
+ gui? (
+ >=dev-libs/protobuf-21.12:=
+ >=dev-libs/sentry-native-0.6.5-r1
+ dev-qt/qtbase:6=[gui,icu,widgets]
+ dev-qt/qtdeclarative:6=[widgets]
+ dev-qt/qtsvg:6=
+ media-libs/mesa
+ net-libs/grpc:=
+ )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.3.2-gui_gentoo.patch
+)
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ xdg_environment_reset
+ default
+ if use gui; then
+ local PATCHES=()
+ BUILD_DIR="${WORKDIR}"/gui_build \
+ CMAKE_USE_DIR="${S}"/internal/frontend/bridge-gui/bridge-gui \
+ cmake_src_prepare
+ fi
+}
+
+src_configure() {
+ if use gui; then
+ # TODO:
+ # - auto-sync version number between the two executables
+ # - can we leave BRIDGE_TAG unset? Seems it gets displayed in some info box
+ local mycmakeargs=(
+ -DBRIDGE_APP_FULL_NAME="Proton Mail Bridge"
+ -DBRIDGE_APP_VERSION="${PV}+git"
+ -DBRIDGE_REPO_ROOT="${S}"
+ -DBRIDGE_TAG="NOTAG"
+ -DBRIDGE_VENDOR="Gentoo Linux"
+ )
+ BUILD_DIR="${WORKDIR}"/gui_build \
+ CMAKE_USE_DIR="${S}"/internal/frontend/bridge-gui/bridge-gui \
+ cmake_src_configure
+ fi
+}
+
+src_compile() {
+ emake build-nogui
+
+ if use gui; then
+ BUILD_DIR="${WORKDIR}"/gui_build \
+ CMAKE_USE_DIR="${S}"/internal/frontend/bridge-gui/bridge-gui \
+ cmake_src_compile
+ fi
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ exeinto /usr/bin
+ newexe bridge ${PN}
+
+ if use gui; then
+ BUILD_DIR="${WORKDIR}"/gui_build \
+ CMAKE_USE_DIR="${S}"/internal/frontend/bridge-gui/bridge-gui \
+ cmake_src_install
+ mv "${ED}"/usr/bin/bridge-gui "${ED}"/usr/bin/${PN}-gui || die
+ fi
+
+ systemd_newuserunit "${FILESDIR}"/${PN}.service-r1 ${PN}.service
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ if [[ -n "${REPLACING_VERSIONS}" ]]; then
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 3.2.0; then
+ ewarn "Please note that since version 3.2.0, ${PN} by default shares usage statistics with upstream."
+ ewarn "For details, please see"
+ ewarn
+ ewarn " https://proton.me/support/share-usage-statistics"
+ ewarn
+ ewarn "This behaviour can be disabled through ${PN}-gui, under Advanced Settings."
+ ewarn
+ break
+ fi
+ done
+ fi
+}