summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-11 22:11:51 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-11 22:11:51 +0200
commitd077a1cbd191f4e81fde7c58fb4b230e5ce48187 (patch)
tree34e68719c5cd01924129cd631d1a1c5e6d43dc19 /mail-filter
parentacct-user/rslsync: add user (175) for net-p2p/resilio-sync (diff)
downloadgentoo-d077a1cbd191f4e81fde7c58fb4b230e5ce48187.tar.gz
gentoo-d077a1cbd191f4e81fde7c58fb4b230e5ce48187.tar.bz2
gentoo-d077a1cbd191f4e81fde7c58fb4b230e5ce48187.zip
mail-filter/postfwd: bump to version 2.03
Closes: https://bugs.gentoo.org/737142 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/postfwd/Manifest1
-rw-r--r--mail-filter/postfwd/postfwd-2.03.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/mail-filter/postfwd/Manifest b/mail-filter/postfwd/Manifest
index 92c099a3a055..8bc9d7b26cd1 100644
--- a/mail-filter/postfwd/Manifest
+++ b/mail-filter/postfwd/Manifest
@@ -1 +1,2 @@
DIST postfwd-2.02.tar.gz 265781 BLAKE2B de63bdab4f7c1b117a16ebed2248f1e89b7c973bb34cee1b3fbbceda8c9d9b92d180fb5de8a332732b69a05d1b157be1c95d81ded003641d78665064a4881432 SHA512 23b48ca7218fba46f4b1887c4c6724112866c2e22e56f749602ba74430c4cf4c8418b9effb400ea4a468a5f137c764cac9611879e37d1585cf6d0b31dd41060f
+DIST postfwd-2.03.tar.gz 266373 BLAKE2B d7d7ab7680ddc7640831b2216d2f1618f1b4561abed6a0c6c5edabebe205496ae41893500b09c9bd76131dbbbed1743af00156417f2fb23c23c03fdddef96e95 SHA512 1f29766e9e7aa8cfd4c86e426ca578670094eb856758bc67d0fbd98ec31f408a5797e0fd93ee81a169014b5376dfc48f71db122a4cfafe0ba757856679f5ff61
diff --git a/mail-filter/postfwd/postfwd-2.03.ebuild b/mail-filter/postfwd/postfwd-2.03.ebuild
new file mode 100644
index 000000000000..9c5901fcc653
--- /dev/null
+++ b/mail-filter/postfwd/postfwd-2.03.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="Versatile Postfix policy server with a flexible ruleset based configuration"
+HOMEPAGE="https://www.postfwd.org/"
+SRC_URI="https://www.postfwd.org/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ acct-group/postfwd
+ acct-user/postfwd
+ dev-lang/perl
+ dev-perl/Net-CIDR-Lite
+ dev-perl/Net-DNS
+ dev-perl/Net-Server
+ dev-perl/NetAddr-IP
+ virtual/perl-Digest-MD5
+ virtual/perl-Storable
+ virtual/perl-Sys-Syslog
+ virtual/perl-Time-HiRes
+"
+
+src_install() {
+ local BIN="postfwd3"
+ # program
+ dosbin sbin/${BIN}
+
+ # man pages and documentation
+ doman man/man8/${BIN}.8
+ dodoc doc/{${BIN}.CHANGELOG,${BIN}.txt}
+
+ # example configuration
+ dodoc etc/${PN}.cf.sample
+
+ # plugins and tools
+ dodoc -r plugins tools
+
+ # start scripts script and respective configuration file
+ newinitd "${FILESDIR}"/${PN}.init.3-r1 ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf.3 ${PN}
+ systemd_newunit "${FILESDIR}"/${PN}.service.3 ${PN}.service
+}
+
+pkg_postinst() {
+ einfo
+ einfo "${PN} has no default configuration for safety reasons. Every"
+ einfo "mail system is different, so you should craft a set of rules"
+ einfo "that is suitable for your environment and save it to:"
+ einfo " ${EROOT}/etc/postfwd.cf"
+ einfo "You can find a sample configuration in:"
+ einfo " ${EROOT}/usr/share/doc/${PF}"
+ einfo
+ einfo "If you want ${PN} to start on system boot, you have to add it your"
+ einfo "default run level if using OpenRC:"
+ einfo " # rc-update add postfwd default"
+ einfo "Also remember to edit ${EROOT}/etc/conf.d/${PN} to your liking."
+ einfo
+ einfo "Or - if you are using systemd - enable the service:"
+ einfo " # systemctl enable postfwd"
+ einfo
+ einfo "A plugins sample folder has been placed under:"
+ einfo
+ einfo " ${EROOT}/usr/share/doc/${PF}/plugins"
+ einfo
+ einfo "You can find additional tools for testing ${PN} in:"
+ einfo " ${EROOT}/usr/share/doc/${PF}/tools"
+
+ ewarn
+ ewarn "Please read the documentation carefully and properly test new"
+ ewarn "rulesets before putting them into production use. Otherwise you"
+ ewarn "risk accidental mail loss or worse."
+ ewarn
+ ewarn "Visit https://www.postfwd.org/ for more information."
+ ewarn
+}