summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-01-17 19:30:07 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-01-20 22:21:44 +0100
commit64af18b7d22eb31b3e2110938c7f1e69d916baef (patch)
treed3dbccf3d2b80e955b9ec28b9a433f491c7f034f /mail-filter
parentapp-vim/vim-multiple-cursors: EAPI8 bump (diff)
downloadgentoo-64af18b7d22eb31b3e2110938c7f1e69d916baef.tar.gz
gentoo-64af18b7d22eb31b3e2110938c7f1e69d916baef.tar.bz2
gentoo-64af18b7d22eb31b3e2110938c7f1e69d916baef.zip
mail-filter/spamprobe: EAPI8 bump, fix bug #724748
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/724748 Closes: https://github.com/gentoo/gentoo/pull/34872 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/spamprobe/spamprobe-1.4d-r3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/mail-filter/spamprobe/spamprobe-1.4d-r3.ebuild b/mail-filter/spamprobe/spamprobe-1.4d-r3.ebuild
new file mode 100644
index 000000000000..a3dc63ef9f30
--- /dev/null
+++ b/mail-filter/spamprobe/spamprobe-1.4d-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Fast, intelligent, automatic spam detector using Bayesian analysis"
+HOMEPAGE="https://spamprobe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="berkdb gif jpeg png"
+
+RDEPEND="
+ berkdb? ( >=sys-libs/db-3.2:* )
+ gif? ( media-libs/giflib:= )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ png? ( media-libs/libpng:0= )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4b-gcc43.patch
+ "${FILESDIR}"/${P}-libpng14.patch
+ "${FILESDIR}"/${P}+db-5.0.patch
+ "${FILESDIR}"/${P}-gcc47.patch
+ "${FILESDIR}"/${P}-giflib5.patch
+ "${FILESDIR}"/${P}-gcc11-const-comp.patch
+)
+
+src_configure() {
+ econf \
+ $(use_with gif) \
+ $(use_with jpeg) \
+ $(use_with png)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/*
+}