summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-09-15 11:18:04 -0400
committerMichael Orlitzky <mjo@gentoo.org>2015-09-15 11:18:23 -0400
commit948a8a4aa89c00dd9f8dac44172d9b05284678c8 (patch)
treec8a30996d716b3623da870869c175e226ba3e59a /mail-filter/pypolicyd-spf
parentdev-util/cppcheck: Version bump (bug 560104, thanks Christian Strahl). (diff)
downloadgentoo-948a8a4aa89c00dd9f8dac44172d9b05284678c8.tar.gz
gentoo-948a8a4aa89c00dd9f8dac44172d9b05284678c8.tar.bz2
gentoo-948a8a4aa89c00dd9f8dac44172d9b05284678c8.zip
mail-filter/pypolicyd-spf: remove python2 support to avoid ipaddress conflict.
Current versions of pypolicyd-spf support both python2 and python3. With python2, the dev-python/ipaddr library provides support for IP address parsing. And with python3 (>= 3.3), the built-in ipaddress module is used. In fact, this determination is made based on the presence (or absence) of the ipaddress module. So far this has been fine. But recently, dev-python/ipaddress was introduced to backport the python3 ipaddress module to python2. Now, when dev-python/ipaddress is detected, pypolicyd-spf (incorrectly) assumes the python3 implementation. This is bug #559364 by Robert Trace. Upstream will be python3-only in the next release. They have suggested that we drop support for python2, and that's what this revision does. Since this can cause mail to be rejected or delayed, the new revision replaces the original. Bug: 559364 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'mail-filter/pypolicyd-spf')
-rw-r--r--mail-filter/pypolicyd-spf/pypolicyd-spf-1.3.2-r1.ebuild (renamed from mail-filter/pypolicyd-spf/pypolicyd-spf-1.3.2.ebuild)27
1 files changed, 8 insertions, 19 deletions
diff --git a/mail-filter/pypolicyd-spf/pypolicyd-spf-1.3.2.ebuild b/mail-filter/pypolicyd-spf/pypolicyd-spf-1.3.2-r1.ebuild
index 080046136cb2..cf6af6ad8908 100644
--- a/mail-filter/pypolicyd-spf/pypolicyd-spf-1.3.2.ebuild
+++ b/mail-filter/pypolicyd-spf/pypolicyd-spf-1.3.2-r1.ebuild
@@ -4,16 +4,13 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-# With >=python-3.3, the built-in ipaddress module handles the parsing
-# of IP addresses. If python is built without ipv6 support, then
-# ipaddress can't parse ipv6 addresses, and the daemon will crash if it
-# sees an ipv6 SPF record. In other words, it's completely broken.
-#
-# Ideally this would remain optional for python-2.x, but until there's
-# an easy way to do that, "maybe annoying" seems a better option than
-# "maybe broken."
+# See bug #559364 before getting clever with this.
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+# The built-in ipaddress module handles the parsing of IP addresses. If
+# python is built without ipv6 support, then ipaddress can't parse ipv6
+# addresses, and the daemon will crash if it sees an ipv6 SPF record. In
+# other words, it's completely broken.
PYTHON_REQ_USE="ipv6"
inherit distutils-r1
@@ -27,15 +24,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-# ipaddr is only needed with <python-3.3.
-#
-# The lower bound on pyspf is not strictly necessary, but some features
-# are silently disabled with older versions of pyspf.
-#
-DEPEND="$(python_gen_cond_dep \
- '>=dev-python/ipaddr-2.1.10[${PYTHON_USEDEP}]' \
- 'python2*')
- >=dev-python/pyspf-2.0.9[${PYTHON_USEDEP}]"
+DEPEND=">=dev-python/pyspf-2.0.9[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
dev-python/authres[${PYTHON_USEDEP}]"