summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2019-06-14 09:28:33 -0400
committerMichael Orlitzky <mjo@gentoo.org>2019-06-14 09:33:49 -0400
commit129704fc9faf6d415a66b48171c1840e30ebf399 (patch)
treecc1827540fd8fed438ffe33a2302c103d8556447 /mail-filter/opendkim
parentsys-boot/vboot-utils: add fts-standalone dep for musl users (diff)
downloadgentoo-129704fc9faf6d415a66b48171c1840e30ebf399.tar.gz
gentoo-129704fc9faf6d415a66b48171c1840e30ebf399.tar.bz2
gentoo-129704fc9faf6d415a66b48171c1840e30ebf399.zip
mail-filter/opendkim: fix building against BerkeleyDB.
Our ebuild was doing something strange with USE=berkdb set, and as a result, the ./configure script for OpenDKIM was not being passed the correct location for the BerkeleyDB headers. This seems like a simple fix; to set --with-db-incdir="$(db_includedir)" in the ebuild. I've made that change in a new revision, and tested that the OpenDKIM build system can pick up the right version of BerkeleyDB: checking for BerkeleyDB db.h... /usr/include/db6.0 Seems to work. Closes: https://bugs.gentoo.org/684958 Signed-off-by: Michael Orlitzky <mjo@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'mail-filter/opendkim')
-rw-r--r--mail-filter/opendkim/opendkim-2.10.3-r14.ebuild (renamed from mail-filter/opendkim/opendkim-2.10.3-r13.ebuild)3
1 files changed, 1 insertions, 2 deletions
diff --git a/mail-filter/opendkim/opendkim-2.10.3-r13.ebuild b/mail-filter/opendkim/opendkim-2.10.3-r14.ebuild
index 037a1b0f98cd..ff45f1dac4db 100644
--- a/mail-filter/opendkim/opendkim-2.10.3-r13.ebuild
+++ b/mail-filter/opendkim/opendkim-2.10.3-r14.ebuild
@@ -68,8 +68,7 @@ src_configure() {
local myconf=()
if use berkdb ; then
myconf+=(
- $(db_includedir)
- --with-db-incdir=${myconf#-I}
+ --with-db-incdir=$(db_includedir)
--enable-popauth
--enable-query_cache
--enable-stats