summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-01-01 12:47:56 -0600
committerAnthony G. Basile <blueness@gentoo.org>2018-01-01 14:58:13 -0500
commite5b1059c8e1dec352bf549be349bd8082623e8db (patch)
treee3935209e810fc8293161dd7723c6c2b4892d133 /mail-client
parentmedia-gfx/imagemagick: Bump to v6.9.9-31 / v7.0.7-19 (diff)
downloadgentoo-e5b1059c8e1dec352bf549be349bd8082623e8db.tar.gz
gentoo-e5b1059c8e1dec352bf549be349bd8082623e8db.tar.bz2
gentoo-e5b1059c8e1dec352bf549be349bd8082623e8db.zip
mail-client/mailx: version bump to 8.1.2.20160123
Closes: https://bugs.gentoo.org/485432 Closes: https://bugs.gentoo.org/554354 Bug: https://bugs.gentoo.org/533208 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mailx/Manifest2
-rw-r--r--mail-client/mailx/mailx-8.1.2.20160123.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/mail-client/mailx/Manifest b/mail-client/mailx/Manifest
index 9ab15c5c5fd0..3e92f4376e64 100644
--- a/mail-client/mailx/Manifest
+++ b/mail-client/mailx/Manifest
@@ -1,2 +1,4 @@
+DIST bsd-mailx_8.1.2-0.20160123cvs-4.debian.tar.xz 45768 BLAKE2B 7e5ae62dee742502ea86c55803615f67b2be082b0fe3e6dbf5f64ca7b63fa79014195f4c2262ffaba23624677227df4a94d3966611e9de4bf491f52e050c88b9 SHA512 79d822b4e0e9796970e96f656814cf835fe522d2e33b79484257af50e631a264f6fae99e225d96fa37f50d7ce9f3b9e9577ddb361a27c6e59af8db4736250c19
+DIST bsd-mailx_8.1.2-0.20160123cvs.orig.tar.bz2 76715 BLAKE2B c6491cd88e99b62184da60cc6f8a42aac5f7f5a828c80c05d3dc4493c77727e553b916cb646dade38214d3a6738c084559764abb812a1dfe1fcce2e4d6a04960 SHA512 b66dd0fc5a150c0e1068b9aedda8425c73be7ac7e22d91f2c52de3f2d416016886f46dd54ec5024c0cd4c7e736aee7bdb68d9117f9b2b455fc42d05e1a677373
DIST mailx_8.1.2-0.20050715cvs-1.diff.gz 36758 BLAKE2B 825e4a62fa2d33e29c25092ec466e07be6be2abed0f1da5623f37be179cbb1212baade400a621fa838eced88a84393078c67c3126774ff08030680f4f0dbdd54 SHA512 6506261f24d5a022fd9cee596a78488a279a0b39b7281cdad9c3e52b5c7f6c2506a1b24970c28cf7b4ffa4ce2d71fec650f42d22959b53aeca0f160b2885b2fe
DIST mailx_8.1.2-0.20050715cvs.orig.tar.gz 94664 BLAKE2B 0b0b9f4db18bda8b6572c97c33784f7e29c16d500b3658b79f31fb80947035e2bfc7eaf6e8bc50e621ee13ae5e61d7760aa882c29f0b082ce8974f7b1aa8416f SHA512 1c1d991a0e522b2e78a49b9c78eed80b1f6d4f68ca0427ef720ebe77a3a2881bcd3d63967ab04f5d6f75fbf2212e260e4a841152f8a69d300c46acd90bb48d68
diff --git a/mail-client/mailx/mailx-8.1.2.20160123.ebuild b/mail-client/mailx/mailx-8.1.2.20160123.ebuild
new file mode 100644
index 000000000000..c900c0745c83
--- /dev/null
+++ b/mail-client/mailx/mailx-8.1.2.20160123.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DP="bsd-${PN}_${PV%.*}-0.${PV##*.}cvs"
+DPT="${DP}.orig.tar.bz2"
+DPP="${DP}-4.debian.tar.xz"
+
+DESCRIPTION="The $ mail program, which is used to send mail via shell scripts"
+HOMEPAGE="http://www.debian.org/"
+SRC_URI="http://http.debian.net/debian/pool/main/b/bsd-${PN}/${DPT}
+ http://http.debian.net/debian/pool/main/b/bsd-${PN}/${DPP}"
+
+S="${WORKDIR}/${DP/_/-}.orig"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=">=net-libs/liblockfile-1.03
+ virtual/mta
+ mail-client/mailx-support"
+
+RDEPEND="${DEPEND}
+ !mail-client/nail
+ !net-mail/mailutils"
+
+src_prepare() {
+ eapply "${WORKDIR}/debian/patches"
+ eapply "${FILESDIR}/${PN}-8.1.2.20050715-offsetof.patch"
+ eapply_user
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) EXTRAFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin mail
+
+ doman mail.1
+
+ dosym mail /usr/bin/Mail
+ dosym mail /usr/bin/mailx
+ dosym mail.1 /usr/share/man/man1/Mail.1
+
+ insinto /usr/share/mailx/
+ doins misc/mail.help misc/mail.tildehelp
+ insinto /etc
+ doins misc/mail.rc
+}