summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 19:44:30 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:12:15 +0100
commit7299b1a2dd358cad83c6f53c6a946f1cee4f3971 (patch)
tree7e171445803ce2b07772e80a78dcb614e674890a /mail-client
parentnet-libs/gsnmp: port to EAPI 7 (diff)
downloadgentoo-7299b1a2dd358cad83c6f53c6a946f1cee4f3971.tar.gz
gentoo-7299b1a2dd358cad83c6f53c6a946f1cee4f3971.tar.bz2
gentoo-7299b1a2dd358cad83c6f53c6a946f1cee4f3971.zip
mail-client/mailx-support: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mailx-support/mailx-support-20060102-r2.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/mail-client/mailx-support/mailx-support-20060102-r2.ebuild b/mail-client/mailx-support/mailx-support-20060102-r2.ebuild
index 5e8b0a377776..590ef932c74a 100644
--- a/mail-client/mailx-support/mailx-support-20060102-r2.ebuild
+++ b/mail-client/mailx-support/mailx-support-20060102-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-inherit epatch toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Provides lockspool utility"
HOMEPAGE="http://www.openbsd.org/"
@@ -12,14 +12,14 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-RDEPEND=""
-DEPEND=""
+PATCHES=(
+ "${FILESDIR}"/${P}-respect-ldflags.patch
+ "${FILESDIR}"/${P}-add-sys_file_h.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${P}-respect-ldflags.patch
- epatch "${FILESDIR}"/${P}-add-sys_file_h.patch
+ default
# This code should only be ran with Gentoo Prefix profiles
if use prefix; then