summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2021-02-27 19:57:37 -0500
committerCraig Andrews <candrews@gentoo.org>2021-07-06 12:27:21 -0400
commit42d5f4de147d9d423cbf0a8433901d662612ace0 (patch)
tree9243a62f2c67957450b9ad0097dcbb08f04e3f60 /mail-client
parentmedia-video/pipewire: combine USE=aac, USE=aptx & USE=ldac in USE=bluetooth (diff)
downloadgentoo-42d5f4de147d9d423cbf0a8433901d662612ace0.tar.gz
gentoo-42d5f4de147d9d423cbf0a8433901d662612ace0.tar.bz2
gentoo-42d5f4de147d9d423cbf0a8433901d662612ace0.zip
mail-client/roundcube: Add 1.5_rc
- Now requires >=dev-lang/php-5.5.0 - intl required to be enabled on dev-lang/php - Added "exif fileinfo zip" USE flags - Updated -9999 ebuild as well Closes: https://bugs.gentoo.org/782883 Closes: 19700 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com> Closes: https://github.com/gentoo/gentoo/pull/19700 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/roundcube/Manifest1
-rw-r--r--mail-client/roundcube/metadata.xml4
-rw-r--r--mail-client/roundcube/roundcube-1.5_rc.ebuild96
-rw-r--r--mail-client/roundcube/roundcube-9999.ebuild6
4 files changed, 104 insertions, 3 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index 199866ecaf74..4f519aef7c5c 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -1 +1,2 @@
DIST roundcubemail-1.4.11-complete.tar.gz 7048262 BLAKE2B aaf5e6ce5b07577f687788730bc9181334402bb2ff5e78fb306425913b62b4a8f72505547bdcc8673806b48b9ba8252b8059b59399efc95a51877d5c672a4760 SHA512 2bfe0ff3716f76bf9eb5bf5f7b62c738b233c57e67d6ac767c044d1a3a694ae003642d9cc68a18d6f6ba94135aa7ee1692db920e9127128669faee9ddf78fe80
+DIST roundcubemail-1.5-rc-complete.tar.gz 7683911 BLAKE2B e67bbb8ad3d5ffa69091c18b519f78a3dc6d4cc1783921aab9de3c86351d2946cbf784267f5db69434da25413ad1f961161289b47408f14d9e6fa26d8b1e0999 SHA512 4e49e91bb53546e6ac348e33e64019afeee2ce6b78caa4375148fc6fac5abbe8e5db42670c5527e3678abe838ddf349275353e7919584d751bf4c321a62fe795
diff --git a/mail-client/roundcube/metadata.xml b/mail-client/roundcube/metadata.xml
index 9564101cfbeb..d07ba4da8522 100644
--- a/mail-client/roundcube/metadata.xml
+++ b/mail-client/roundcube/metadata.xml
@@ -25,6 +25,10 @@
Add dependencies to support server-side GnuPG signing
and/or encryption through the enigma plugin
</flag>
+ <flag name="fileinfo">
+ Use the dev-lang/php fileinfo extension to guess the
+ mime_type of attachments
+ </flag>
<flag name="ldap">
Add dependencies to support connecting to an LDAP address
book server
diff --git a/mail-client/roundcube/roundcube-1.5_rc.ebuild b/mail-client/roundcube/roundcube-1.5_rc.ebuild
new file mode 100644
index 000000000000..9052cdcb124f
--- /dev/null
+++ b/mail-client/roundcube/roundcube-1.5_rc.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_PV=${PV/_/-}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="https://roundcube.net"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+
+IUSE="change-password enigma exif fileinfo ldap mysql postgres sqlite ssl spell zip"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+RDEPEND="
+ ${DEPEND}
+ >=dev-lang/php-5.5.0[exif?,fileinfo?,filter,gd,iconv,intl,json(+),ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml,zip?]
+ virtual/httpd-php
+ change-password? (
+ dev-lang/php[sockets]
+ )
+ enigma? (
+ app-crypt/gnupg
+ )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ spell? ( dev-lang/php[curl,spell] )
+"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/roundcube/roundcubemail"
+ EGIT_BRANCH="master"
+ BDEPEND="${BDEPEND}
+ app-arch/unzip
+ dev-php/composer
+ net-misc/curl"
+else
+ SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${MY_PV}/${MY_P}-complete.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+src_unpack() {
+ if [[ "${PV}" == *9999* ]]; then
+ git-r3_src_unpack
+ pushd "${S}" > /dev/null || die
+ mv composer.json-dist composer.json || die
+ composer install --no-dev || die
+ ./bin/install-jsdeps.sh || die
+ popd > /dev/null || die
+ else
+ default
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.md INSTALL README.md UPGRADING SECURITY.md
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+ webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE_complete.txt"
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "You can review the post-upgrade instructions at:"
+ elog "${EROOT}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
+ fi
+}
diff --git a/mail-client/roundcube/roundcube-9999.ebuild b/mail-client/roundcube/roundcube-9999.ebuild
index 5df9f9d2a851..9052cdcb124f 100644
--- a/mail-client/roundcube/roundcube-9999.ebuild
+++ b/mail-client/roundcube/roundcube-9999.ebuild
@@ -16,7 +16,7 @@ HOMEPAGE="https://roundcube.net"
# for bundled PEAR components, googiespell and utf8.class.php
LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
-IUSE="change-password enigma ldap mysql postgres sqlite ssl spell"
+IUSE="change-password enigma exif fileinfo ldap mysql postgres sqlite ssl spell zip"
REQUIRED_USE="|| ( mysql postgres sqlite )"
# this function only sets DEPEND so we need to include that in RDEPEND
@@ -24,7 +24,7 @@ need_httpd_cgi
RDEPEND="
${DEPEND}
- >=dev-lang/php-5.4.0[filter,gd,iconv,json(+),ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml]
+ >=dev-lang/php-5.5.0[exif?,fileinfo?,filter,gd,iconv,intl,json(+),ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml,zip?]
virtual/httpd-php
change-password? (
dev-lang/php[sockets]
@@ -71,7 +71,7 @@ src_unpack() {
src_install() {
webapp_src_preinst
- dodoc CHANGELOG.md INSTALL README.md UPGRADING
+ dodoc CHANGELOG.md INSTALL README.md UPGRADING SECURITY.md
insinto "${MY_HTDOCSDIR}"
doins -r [[:lower:]]* SQL