summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-11-05 22:55:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-23 08:11:35 +0100
commit438402087c2e77d302bb943cd0bfc25bfc5166b8 (patch)
treeab28dbf0fe64ae21ddf6419c6af0e8a5bdbc60b5 /lxqt-base/lxqt-openssh-askpass
parentlxqt-base/lxqt-sudo: add version 0.16.0 (diff)
downloadgentoo-438402087c2e77d302bb943cd0bfc25bfc5166b8.tar.gz
gentoo-438402087c2e77d302bb943cd0bfc25bfc5166b8.tar.bz2
gentoo-438402087c2e77d302bb943cd0bfc25bfc5166b8.zip
lxqt-base/lxqt-openssh-askpass: add version 0.16.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'lxqt-base/lxqt-openssh-askpass')
-rw-r--r--lxqt-base/lxqt-openssh-askpass/Manifest1
-rw-r--r--lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-0.16.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-openssh-askpass/Manifest b/lxqt-base/lxqt-openssh-askpass/Manifest
index 8c6edf040884..70682edad351 100644
--- a/lxqt-base/lxqt-openssh-askpass/Manifest
+++ b/lxqt-base/lxqt-openssh-askpass/Manifest
@@ -1 +1,2 @@
DIST lxqt-openssh-askpass-0.15.0.tar.xz 17032 BLAKE2B 3a6e235477d3499429f854351f4f8686f6aaec2c8ee114fab32acd0a6759cc6e782c5afda7e1b0e496346673838938fa083322d4dc147380a918209f5c0ab0a6 SHA512 e9dd41dd75892be234e6381670fa0b836bf040b00b7c59c7f23cadc9a916e8c646c4d44645a49183a305c6b755a01e6b8e6a3c0f84aa7c374cdb3ddd577e2f44
+DIST lxqt-openssh-askpass-0.16.0.tar.xz 17160 BLAKE2B cc16e4cb884530eb76ffa27f4cb207edc774c0f859cefa995a8ff395e9c166ab5ffa24e898b23c61e49fd3a9d5d8be83480cee0dacd2791609e16ce5a92debd2 SHA512 4251ecb10255e4ef2b988b162111c2889c432bf039d05ae00c3f16992424e7a27868b0e040899592cc703a7b009a197c8bdda3698e3c6ea41cf9d22c3ddddb80
diff --git a/lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-0.16.0.ebuild b/lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-0.16.0.ebuild
new file mode 100644
index 000000000000..e2a68f97d299
--- /dev/null
+++ b/lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-0.16.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt OpenSSH user password prompt tool"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.8.0
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"
+
+src_install() {
+ cmake_src_install
+ doman man/*.1
+
+ newenvd - 99${PN} <<- _EOF_
+ SSH_ASKPASS='${EPREFIX}/usr/bin/lxqt-openssh-askpass'
+ _EOF_
+}