summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /lxqt-base/lxqt-about
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'lxqt-base/lxqt-about')
-rw-r--r--lxqt-base/lxqt-about/Manifest3
-rw-r--r--lxqt-base/lxqt-about/lxqt-about-0.7.0.ebuild25
-rw-r--r--lxqt-base/lxqt-about/lxqt-about-0.8.0.ebuild39
-rw-r--r--lxqt-base/lxqt-about/lxqt-about-0.9.0.ebuild31
-rw-r--r--lxqt-base/lxqt-about/metadata.xml9
5 files changed, 107 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-about/Manifest b/lxqt-base/lxqt-about/Manifest
new file mode 100644
index 000000000000..b4c44bade80e
--- /dev/null
+++ b/lxqt-base/lxqt-about/Manifest
@@ -0,0 +1,3 @@
+DIST lxqt-about-0.7.0.tar.xz 10384 SHA256 5f1b53862f528aab8173626efbc6737dc228aa127c27c221123133401033e4de SHA512 e73512f040ec392079b5242a4bb7df69949bf516b2ec5e03534be2d13dc11cf252502a32c4da6b8ee9b00282c8e7e42395dae068c6e7fee4522f2dee230d24bd WHIRLPOOL 23a51940bbe4b9d4d82e452d1c3896f16d92ece3dce5b0b9420fd43c190bb0465d4a8278161957c2c6f187fedc60207fe30f955ee2c1eed6cdf946e3b4304b25
+DIST lxqt-about-0.8.0.tar.xz 10628 SHA256 30c3a219034732c22d1bad29c24962157449006748939e07255fb4b866b72a83 SHA512 e40dcbd42ea950ba18faa4004136462fbe06b69856102c82bd97561d057ee391bfc1d31d009b1b0c83fd0a6bdaf4b0c4492e08cd34e7763052bead2b58b28e8e WHIRLPOOL 43ca7d4af27938059904436fa4c9405ea791058cb17b9fdea08444433c84b55e6e7d81449d5672d1ccb0e0de9e4f8831c74e628711cf11e44474a4efdcd7f8a0
+DIST lxqt-about-0.9.0.tar.xz 10448 SHA256 6965eb5eba8acbd97cebd708da12f2aa8bbb3cf2c3fa211b5c00cc45fc48bf77 SHA512 baf484fc27b5c548319b6ee224f6ce3a006cf7a48993964baea7e186fa68cf4aaea0766bfabb11b757a175061118b6555b882d750176acd21210c13901c4bfce WHIRLPOOL 0d3885e3c34d59e226a3dd758965c5ee925f7420ca7e9da1ef77a87a953054f5cb5f6813a5644645262ac27c130144944e5668d6543da21ba2754d432754ee72
diff --git a/lxqt-base/lxqt-about/lxqt-about-0.7.0.ebuild b/lxqt-base/lxqt-about/lxqt-about-0.7.0.ebuild
new file mode 100644
index 000000000000..837a5e914677
--- /dev/null
+++ b/lxqt-base/lxqt-about/lxqt-about-0.7.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt about dialog"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S=${WORKDIR}
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+DEPEND="dev-qt/qtgui:4
+ ~lxqt-base/liblxqt-${PV}"
+RDEPEND="${DEPEND}"
diff --git a/lxqt-base/lxqt-about/lxqt-about-0.8.0.ebuild b/lxqt-base/lxqt-about/lxqt-about-0.8.0.ebuild
new file mode 100644
index 000000000000..e496e3818099
--- /dev/null
+++ b/lxqt-base/lxqt-about/lxqt-about-0.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt about dialog"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ ~lxqt-base/liblxqt-${PV}
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT5=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/lxqt-base/lxqt-about/lxqt-about-0.9.0.ebuild b/lxqt-base/lxqt-about/lxqt-about-0.9.0.ebuild
new file mode 100644
index 000000000000..8091ba4e9fa0
--- /dev/null
+++ b/lxqt-base/lxqt-about/lxqt-about-0.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt about dialog"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ ~lxqt-base/liblxqt-${PV}
+"
+RDEPEND="${DEPEND}"
diff --git a/lxqt-base/lxqt-about/metadata.xml b/lxqt-base/lxqt-about/metadata.xml
new file mode 100644
index 000000000000..d89dead0ed86
--- /dev/null
+++ b/lxqt-base/lxqt-about/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>lxqt</herd>
+ <maintainer>
+ <email>jauhien@gentoo.org</email>
+ <name>Jauhien Piatlicki</name>
+ </maintainer>
+</pkgmetadata>