summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2019-08-19 11:24:27 +0200
committerHanno <hanno@gentoo.org>2019-08-19 11:24:27 +0200
commite49a1a8936e132cf687a13c49407b0589f466985 (patch)
tree2083e3969716eb047a84d645ecf3ed7131bbc199 /lxde-base
parentnet-im/gajim: Fix wrong PYTHON_USEDEP. (diff)
downloadgentoo-e49a1a8936e132cf687a13c49407b0589f466985.tar.gz
gentoo-e49a1a8936e132cf687a13c49407b0589f466985.tar.bz2
gentoo-e49a1a8936e132cf687a13c49407b0589f466985.zip
lxde-base/lxsession: Remove unneeded libgee dependency.
Closes: https://bugs.gentoo.org/691518 Signed-off-by: Hanno Boeck <hanno@gentoo.org> Package-Manager: Portage-2.3.72, Repoman-2.3.17
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxsession/lxsession-0.5.4-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/lxde-base/lxsession/lxsession-0.5.4-r1.ebuild b/lxde-base/lxsession/lxsession-0.5.4-r1.ebuild
new file mode 100644
index 000000000000..3c2f2eae2188
--- /dev/null
+++ b/lxde-base/lxsession/lxsession-0.5.4-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit vala autotools
+
+DESCRIPTION="LXDE session manager"
+HOMEPAGE="https://wiki.lxde.org/en/LXSession"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~x86 ~x86-linux"
+SLOT="0"
+
+# upower USE flag is enabled by default in the desktop profile
+IUSE="nls upower"
+
+COMMON_DEPEND="
+ dev-libs/glib:2
+ dev-libs/dbus-glib
+ dev-libs/libunique:1
+ lxde-base/lxde-common
+ sys-auth/polkit
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ sys-apps/dbus
+"
+RDEPEND="${COMMON_DEPEND}
+ !lxde-base/lxsession-edit
+ sys-apps/lsb-release
+ upower? ( sys-power/upower )
+"
+DEPEND="${COMMON_DEPEND}
+ $(vala_depend)
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+
+PATCHES=(
+ # Fedora patches
+ "${FILESDIR}"/${PN}-0.5.2-reload.patch
+ "${FILESDIR}"/${PN}-0.5.2-notify-daemon-default.patch
+ "${FILESDIR}"/${PN}-0.5.2-fix-invalid-memcpy.patch
+)
+
+src_prepare() {
+ vala_src_prepare
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # dbus is used for restart/shutdown (CK, logind?), and suspend/hibernate (UPower)
+ # gtk3 looks to not be ready, follow what other distributions are
+ # doing
+ econf \
+ $(use_enable nls) \
+ --disable-gtk3
+}