summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-24 23:15:53 +0100
committerSam James <sam@gentoo.org>2023-10-24 23:36:07 +0100
commite06328456e8863698ff3990ec4b70373d817305c (patch)
treeed3d899098e5af7329640a601c40f8e273ec3206 /kde-plasma
parentkde-plasma/systemsettings: 5.27.9 version bump (diff)
downloadgentoo-e06328456e8863698ff3990ec4b70373d817305c.tar.gz
gentoo-e06328456e8863698ff3990ec4b70373d817305c.tar.bz2
gentoo-e06328456e8863698ff3990ec4b70373d817305c.zip
kde-plasma/xdg-desktop-portal-kde: 5.27.9 version bump
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/Manifest1
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.27.9.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/kde-plasma/xdg-desktop-portal-kde/Manifest b/kde-plasma/xdg-desktop-portal-kde/Manifest
index e1d3a7af1332..a709be437fbc 100644
--- a/kde-plasma/xdg-desktop-portal-kde/Manifest
+++ b/kde-plasma/xdg-desktop-portal-kde/Manifest
@@ -1 +1,2 @@
DIST xdg-desktop-portal-kde-5.27.8.tar.xz 142484 BLAKE2B 966a877eb054bf514d6a0ee1786a8732f4fc965250f2b153fe70f336000764e449a15c24350ce405c9929924cd41743d096dd40d128ceb8995f423a4eb96aa47 SHA512 a53776715136c12b5ad6ad3efd5ecc9202665fcaa0f69940a87ddb4ac5021b4f1cf7e77ad25ec9b9b544df322110f639a6fb53b150c15a60c9e6c6a54c7b4018
+DIST xdg-desktop-portal-kde-5.27.9.tar.xz 142456 BLAKE2B 414e6bcf2d25407f83104a25ae3385c7a0db39f9fd5b1ae078e3b6610d61213f01d35cda7b9ce0f168d850f002f14d1064adf39ac9c2b02d0d84f3facddf8f12 SHA512 df34970015ddc778b7fe00f4e8f11f58b328644d105f9df6fe6078edc8e72ed9ececbd065514c001e93d32bcf0c6a704363fe7b4859ce3a3c14703b7fc6b71df
diff --git a/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.27.9.ebuild b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.27.9.ebuild
new file mode 100644
index 000000000000..c8ca6bbf31dc
--- /dev/null
+++ b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.27.9.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+KFMIN=5.106.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.9
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal that is using Qt/KDE Frameworks"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+COMMON_DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtprintsupport-${QTMIN}:5[cups]
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5[dbus]
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/kglobalaccel-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ x11-libs/libxkbcommon
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.7.0
+ >=dev-libs/wayland-protocols-1.25
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+"
+RDEPEND="${COMMON_DEPEND}
+ kde-misc/kio-fuse:5
+ sys-apps/xdg-desktop-portal
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ virtual/pkgconfig
+"