summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-03-22 23:27:06 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-03-23 00:01:03 +0100
commit5d9525a3b3b9fbca4d66d6e144cb8e809e0c224b (patch)
tree37d9c4f5f44b7c9822191eec2521ac15e85ee482 /kde-plasma
parentkde-plasma/kwallet-pam: drop 5.27.3 (diff)
downloadgentoo-5d9525a3b3b9fbca4d66d6e144cb8e809e0c224b.tar.gz
gentoo-5d9525a3b3b9fbca4d66d6e144cb8e809e0c224b.tar.bz2
gentoo-5d9525a3b3b9fbca4d66d6e144cb8e809e0c224b.zip
kde-plasma/plasma-pa: Backport 5.27.4 fixes
Upstream commits: 1e4d0d567a72d444dff1f90bb9c1712212d6e07e 82a276183fac1ca79d7fe2a14d3f19e9a96ba830 KDE-bug: https://bugs.kde.org/show_bug.cgi?id=465996 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/plasma-pa/files/plasma-pa-5.27.3-fix-show-virtual-devices.patch31
-rw-r--r--kde-plasma/plasma-pa/files/plasma-pa-5.27.3-improve-DeviceListItem-sizing.patch67
-rw-r--r--kde-plasma/plasma-pa/plasma-pa-5.27.3-r1.ebuild41
3 files changed, 139 insertions, 0 deletions
diff --git a/kde-plasma/plasma-pa/files/plasma-pa-5.27.3-fix-show-virtual-devices.patch b/kde-plasma/plasma-pa/files/plasma-pa-5.27.3-fix-show-virtual-devices.patch
new file mode 100644
index 000000000000..042323757028
--- /dev/null
+++ b/kde-plasma/plasma-pa/files/plasma-pa-5.27.3-fix-show-virtual-devices.patch
@@ -0,0 +1,31 @@
+From 1e4d0d567a72d444dff1f90bb9c1712212d6e07e Mon Sep 17 00:00:00 2001
+From: Fushan Wen <qydwhotmail@gmail.com>
+Date: Sat, 18 Mar 2023 16:31:57 +0800
+Subject: [PATCH] applet: add missing function for "Show virtual devices" menu
+ item
+
+BUG: 465996
+FIXED-IN: 5.27.4
+(cherry picked from commit 5430caf2483203de5f3047408582bec953aa8946)
+---
+ applet/contents/ui/main.qml | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/applet/contents/ui/main.qml b/applet/contents/ui/main.qml
+index aa595204..f65ec85d 100644
+--- a/applet/contents/ui/main.qml
++++ b/applet/contents/ui/main.qml
+@@ -754,6 +754,10 @@ Item {
+ KQCAddons.KCMShell.openSystemSettings("kcm_pulseaudio");
+ }
+
++ function action_showVirtualDevices() {
++ Plasmoid.configuration.showVirtualDevices = !Plasmoid.configuration.showVirtualDevices;
++ }
++
+ Component.onCompleted: {
+ MicrophoneIndicator.init();
+
+--
+GitLab
+
diff --git a/kde-plasma/plasma-pa/files/plasma-pa-5.27.3-improve-DeviceListItem-sizing.patch b/kde-plasma/plasma-pa/files/plasma-pa-5.27.3-improve-DeviceListItem-sizing.patch
new file mode 100644
index 000000000000..b37d08a745fd
--- /dev/null
+++ b/kde-plasma/plasma-pa/files/plasma-pa-5.27.3-improve-DeviceListItem-sizing.patch
@@ -0,0 +1,67 @@
+From b6715dc950ab5019542f2f7a77e9f2aa4afab9dc Mon Sep 17 00:00:00 2001
+From: Oliver Beard <olib141@outlook.com>
+Date: Tue, 21 Mar 2023 20:19:38 +0000
+Subject: [PATCH] kcm/DeviceListItem: Set width for comboboxes, with correctly
+ sized popup
+
+This commit sets a preferred width for the port/profile comboboxes, so that they appear consistent. The full names are visible by opening the combobox, as the popup is now sized to show the full name. It is also ensured that the popup is positioned correctly to not go off the page when wide.
+
+
+(cherry picked from commit 82a276183fac1ca79d7fe2a14d3f19e9a96ba830)
+---
+ src/kcm/package/contents/ui/DeviceListItem.qml | 18 ++++++++++++++++--
+ 1 file changed, 16 insertions(+), 2 deletions(-)
+
+diff --git a/src/kcm/package/contents/ui/DeviceListItem.qml b/src/kcm/package/contents/ui/DeviceListItem.qml
+index 714884c2..09feea71 100644
+--- a/src/kcm/package/contents/ui/DeviceListItem.qml
++++ b/src/kcm/package/contents/ui/DeviceListItem.qml
+@@ -94,7 +94,7 @@ ColumnLayout {
+
+ readonly property var ports: Ports
+
+- Layout.minimumWidth: Kirigami.Units.gridUnit * 10
++ Layout.preferredWidth: Kirigami.Units.gridUnit * 10
+ visible: portBox.count > 1
+
+ onModelChanged: currentIndex = ActivePortIndex
+@@ -119,6 +119,13 @@ ColumnLayout {
+ }
+ model = items;
+ }
++
++ // Ensure the popup is sufficiently wide to list *full* device names
++ // and is correctly positioned to not go off the page
++ popup.width: Math.max(implicitWidth, width)
++ popup.leftMargin: delegate.ListView.view.Layout.leftMargin
++ popup.rightMargin: delegate.ListView.view.Layout.rightMargin
++ popup.x: mirrored ? 0 : width - popup.width
+ }
+
+ Label {
+@@ -133,7 +140,7 @@ ColumnLayout {
+
+ readonly property var card: paCardModel.data(paCardModel.indexOfCardNumber(CardIndex), paCardModel.role("PulseObject"))
+
+- Layout.minimumWidth: Kirigami.Units.gridUnit * 12
++ Layout.preferredWidth: Kirigami.Units.gridUnit * 12
+ visible: profileBox.count > 1
+ textRole: "description"
+
+@@ -141,6 +148,13 @@ ColumnLayout {
+ currentIndex: card ? model.indexOf(card.profiles[card.activeProfileIndex]) : -1
+
+ onActivated: index => card.activeProfileIndex = card.profiles.indexOf(model[index])
++
++ // Ensure the popup is sufficiently wide to list *full* device names
++ // and is correctly positioned to not go off the page
++ popup.width: Math.max(implicitWidth, width)
++ popup.leftMargin: delegate.ListView.view.Layout.leftMargin
++ popup.rightMargin: delegate.ListView.view.Layout.rightMargin
++ popup.x: mirrored ? 0 : width - popup.width
+ }
+ }
+
+--
+GitLab
+
diff --git a/kde-plasma/plasma-pa/plasma-pa-5.27.3-r1.ebuild b/kde-plasma/plasma-pa/plasma-pa-5.27.3-r1.ebuild
new file mode 100644
index 000000000000..c758fefd0a93
--- /dev/null
+++ b/kde-plasma/plasma-pa/plasma-pa-5.27.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=5.102.0
+QTMIN=5.15.7
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Plasma applet for audio volume management using PulseAudio"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/glib:2
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/kglobalaccel-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ media-libs/libcanberra
+ media-libs/libpulse
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ x11-themes/sound-theme-freedesktop
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:5"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-show-virtual-devices.patch" # KDE-bug 465996
+ "${FILESDIR}/${P}-improve-DeviceListItem-sizing.patch"
+)