summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-24 23:12:18 +0100
committerSam James <sam@gentoo.org>2023-10-24 23:35:50 +0100
commit33544d8496ae746e52f62e39acbb7a0a8348f301 (patch)
tree0cd9191b562d21f28b2dcc3fd392f5d7e64e41e2 /kde-plasma
parentkde-plasma/ksystemstats: 5.27.9 version bump (diff)
downloadgentoo-33544d8496ae746e52f62e39acbb7a0a8348f301.tar.gz
gentoo-33544d8496ae746e52f62e39acbb7a0a8348f301.tar.bz2
gentoo-33544d8496ae746e52f62e39acbb7a0a8348f301.zip
kde-plasma/kwallet-pam: 5.27.9 version bump
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.27.9.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index 34522a7142e6..ace83b809c24 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1 +1,2 @@
DIST kwallet-pam-5.27.8.tar.xz 22876 BLAKE2B a9975b4609e309384aaf767ecc9c2819e25c016be3587a57ba6f73773951c2ce32ced420243ea3c63e5aff5652b676e0a28433f4addae820233d3af847396360 SHA512 fd608811783eac6862055e89ef67f3cdb5d4482eb2a27289460052e058e3a28d03b65e10425b766005c51cb83d1e134c5e2f7f797acf6cadbd1362c216d444ee
+DIST kwallet-pam-5.27.9.tar.xz 22876 BLAKE2B 5b7d247a9e64c5979140d9424508fc699c9c487f3582925f93285fd372e79a08dc08ca393865b5b4bc8f1f24ca35ad88a35ea4a19c65c1ec88db205f458e7279 SHA512 98905aa381bcf8cf6925ac2ec3e4bdef81bfd37ad1eb265307315ccce568020011cd0e03f846b27ebd1fe785b138de1b4cecdae71ecd81f765a25526526c474f
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.27.9.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.27.9.ebuild
new file mode 100644
index 000000000000..cfb8a1b64668
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.27.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.102.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm plasma.kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}