summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-27 19:01:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-28 00:23:09 +0200
commit08ffa6c7cf76bf15f6fc8ff6d058ded7db2c3168 (patch)
tree9aae10bd0ffa6764706f0ea979372c238f080229 /kde-plasma/plasma-integration
parentkde-plasma/plasma-firewall: 6.0.90 version bump (diff)
downloadgentoo-08ffa6c7cf76bf15f6fc8ff6d058ded7db2c3168.tar.gz
gentoo-08ffa6c7cf76bf15f6fc8ff6d058ded7db2c3168.tar.bz2
gentoo-08ffa6c7cf76bf15f6fc8ff6d058ded7db2c3168.zip
kde-plasma/plasma-integration: 6.0.90 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-6.0.90.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 1176bc3449ed..7d63b8a4d60d 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,2 +1,3 @@
DIST plasma-integration-5.27.11.tar.xz 89460 BLAKE2B b6e0f487332c7280d394c9e84c44f18cd0694812307fdb1109a27d7f04ac5e0b2c6934adfed10fcbb65b5ec358e4ece728c8761edbc2872f33b40d3cff54495f SHA512 34e040425a11089bdda444132c224af8b4fca5d3fd30e875d4a385ad26bb215409c076c19ee3a2bbe3736121a7988bbc6ca564814f4e28b8e20acb5ebc194347
DIST plasma-integration-6.0.5.tar.xz 92464 BLAKE2B 7bf1ae70de4e0eeb9402eeeb37e2a29735b97476d673974e30f90d50ca06612d341184e811b1ff86c4d6f12b99e4b5c341f74b92f96264b5f16cc36927ead3f1 SHA512 54c1dd96610cfa479cf4edf2b937ef1543a42ec3edec29c515ed3db49093b7ea2e5ec425d70142e47e9bcf95c28747fb1e28cd0e5dba28ba4a7515a146c0ff0c
+DIST plasma-integration-6.0.90.tar.xz 93096 BLAKE2B 47e3b01acd7926a0816d5a066f90ddc17b3f805fc4670fe511bbe8394450850195ce11bb79a9a00933040c075a8a8b2d1def579f32d763b13f459c42f8ca0c67 SHA512 fcce3f49094f6228cbe3beddca26da8a9f191ebfb01c41b0d2f64bec1e54cb28b04d3895788e861fc5264af7039edd46527dab9d633410fb5fe3ef55c843456e
diff --git a/kde-plasma/plasma-integration/plasma-integration-6.0.90.ebuild b/kde-plasma/plasma-integration/plasma-integration-6.0.90.ebuild
new file mode 100644
index 000000000000..45c4bdeeddd4
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-6.0.90.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KF5MIN=5.115.0
+KFMIN=6.2.0
+PVCUT=$(ver_cut 1-3)
+QT5MIN=5.15.12
+QTMIN=6.7.1
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+
+LICENSE="LGPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="qt5"
+
+# requires running kde environment
+RESTRICT="test"
+
+# slot ops: qdbus*_p.h and Qt6::GuiPrivate for qtx11extras_p.h
+COMMON_DEPEND="
+ dev-libs/wayland
+ >=dev-qt/qtbase-${QTMIN}:6=[dbus,gui,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=dev-qt/qtwayland-${QTMIN}:6
+ >=kde-frameworks/kcolorscheme-${KFMIN}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kguiaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kstatusnotifieritem-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+ x11-libs/libXcursor
+ x11-libs/libxcb
+ qt5? (
+ >=dev-qt/qtdbus-${QT5MIN}:5
+ >=dev-qt/qtgui-${QT5MIN}:5=[dbus]
+ >=dev-qt/qtquickcontrols2-${QT5MIN}:5
+ >=dev-qt/qtwayland-${QT5MIN}:5
+ >=dev-qt/qtwidgets-${QT5MIN}:5
+ >=dev-qt/qtx11extras-${QT5MIN}:5
+ >=kde-frameworks/kcompletion-${KF5MIN}:5
+ >=kde-frameworks/kconfig-${KF5MIN}:5
+ >=kde-frameworks/kconfigwidgets-${KF5MIN}:5
+ >=kde-frameworks/kcoreaddons-${KF5MIN}:5
+ >=kde-frameworks/kguiaddons-${KF5MIN}:5
+ >=kde-frameworks/ki18n-${KF5MIN}:5
+ >=kde-frameworks/kiconthemes-${KF5MIN}:5
+ >=kde-frameworks/kio-${KF5MIN}:5
+ >=kde-frameworks/kjobwidgets-${KF5MIN}:5
+ >=kde-frameworks/knotifications-${KF5MIN}:5
+ >=kde-frameworks/kwindowsystem-${KF5MIN}:5
+ >=kde-frameworks/kxmlgui-${KF5MIN}:5
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.11.1
+"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+ media-fonts/noto-emoji
+"
+PDEPEND="
+ >=kde-plasma/xdg-desktop-portal-kde-${PVCUT}:6
+"
+BDEPEND="
+ >=dev-qt/qtwayland-${QTMIN}:6
+ qt5? ( >=dev-qt/qtwaylandscanner-${QT5MIN}:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_QT6=ON
+ -DBUILD_QT5=$(usex qt5)
+ )
+ ecm_src_configure
+}