summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-09 12:40:42 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-09 13:44:39 +0200
commitd26f2b068bcf024c6ad30fc227cc02eccbb797ae (patch)
tree1ac2b23f2ebc21dcad4a89018194a2226f0698dc /kde-plasma/kwallet-pam
parentdev-libs/libburn: Remove old libburn-1.5.0. (diff)
downloadgentoo-d26f2b068bcf024c6ad30fc227cc02eccbb797ae.tar.gz
gentoo-d26f2b068bcf024c6ad30fc227cc02eccbb797ae.tar.bz2
gentoo-d26f2b068bcf024c6ad30fc227cc02eccbb797ae.zip
kde-plasma: Add KDE Plasma 5.19.0
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.19.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index 175e56f71333..9401c28e9f81 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1 +1,2 @@
DIST kwallet-pam-5.18.5.tar.xz 19800 BLAKE2B 695fb89d1a54bfc44b06bee4881ae357a42c82b6506a6ed7966c30bb28137ee379ac1beb9391982c15ac63e95c0a1bbba2e0950ee89e050a2ceaf296b98958d4 SHA512 050b3ca66f3b078bb7bccb4a3b7750787bf22d18af60972969f83141b99eac4441fa08d48022278cfe28c8f96f7a1d9ca346f155d8ddbdb60b17bc9c142521cc
+DIST kwallet-pam-5.19.0.tar.xz 19844 BLAKE2B eac2b22febe8eef49ddb7f17707bfb6d2e5bc9dff5fd7b458d4e1cb9cdadf93046705d11b2bfcb8a3dc34d8a4cf874cd1bfa99b5b042d2bc632ae55f130dc960 SHA512 0191fdfad14853d1ead9bd18786ea5885814129cfc0b49bec556b3ce8b75a6cf1d47cec4c683ff2477cfbfb9ce5ebc263455fda05181d69b88988a5dc9e84d0b
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.19.0.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.19.0.ebuild
new file mode 100644
index 000000000000..7f2939b271af
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.19.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.70.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ dev-libs/libgcrypt:0=
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}