summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-13 13:38:21 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-13 13:50:48 +0200
commit8b89608fdb2eea0d85e35593d15e4d7686ffd804 (patch)
tree89aa037dec23dede654ef045de926d7ad6b38886 /kde-plasma/kwallet-pam
parentkde-plasma/ksysguard: 5.20.0 version bump (diff)
downloadgentoo-8b89608fdb2eea0d85e35593d15e4d7686ffd804.tar.gz
gentoo-8b89608fdb2eea0d85e35593d15e4d7686ffd804.tar.bz2
gentoo-8b89608fdb2eea0d85e35593d15e4d7686ffd804.zip
kde-plasma/kwallet-pam: 5.20.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.20.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index e615c373baa5..46e5899b5335 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1 +1,2 @@
DIST kwallet-pam-5.19.5.tar.xz 19932 BLAKE2B 28d8419f500c163ba15a79cc994af70b723dff24fa8c32e899bd856766290f20d09e3ee98e164d55596d1b97137e92096f9c2c3cf2386bb700aa0b7bcfed1c39 SHA512 3fe30f979f6ee838b073b7afdb406068f90529fbbac3513d65145f6a46ab8ba0b61ba11a3e9192c60b1ddd50e9af448c1298725fc01dca483b40a8030053095d
+DIST kwallet-pam-5.20.0.tar.xz 19860 BLAKE2B 03c294114df176089dbf2f24f6b30b7a60c75aae8065b53841115c6ad388040b27cf551303f310f112672c2031fc2d50dd773f67fa02d844419005f9e4a117fd SHA512 99c715222adb5c1d825981d2898528e01ee84887fd12e6cc9dfcab86edd5c3325a71bfb394d7d9e60f4cc1388d1e36410b34f579e2c840a121867787460f7b09
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.20.0.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.20.0.ebuild
new file mode 100644
index 000000000000..121f17823eb9
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.20.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.74.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}