summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-27 19:56:14 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-27 21:24:09 +0100
commitfb9e4f2d54dad43d39c2ae04a45e790d460bf6b1 (patch)
treecd2e14c7b513dcb87e546c3ed9b4feadc1bb121a /kde-plasma/ksysguard
parentnet-dns/pdns-recursor: Stable on am64/x86, bug #671982 (diff)
downloadgentoo-fb9e4f2d54dad43d39c2ae04a45e790d460bf6b1.tar.gz
gentoo-fb9e4f2d54dad43d39c2ae04a45e790d460bf6b1.tar.bz2
gentoo-fb9e4f2d54dad43d39c2ae04a45e790d460bf6b1.zip
kde-plasma: Add KDE Plasma 5.14.4
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksysguard')
-rw-r--r--kde-plasma/ksysguard/Manifest1
-rw-r--r--kde-plasma/ksysguard/ksysguard-5.14.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/ksysguard/Manifest b/kde-plasma/ksysguard/Manifest
index 291e87ff9b34..fa574625dea1 100644
--- a/kde-plasma/ksysguard/Manifest
+++ b/kde-plasma/ksysguard/Manifest
@@ -1,2 +1,3 @@
DIST ksysguard-5.13.5.tar.xz 497776 BLAKE2B 15daec09221993a9c5f39845a3cd168d01ee9a367020312507ac96615722fdf0e5244b3130dd5f09905db8a95b7ddf5df58cdada64a1e291c069f1b58912e684 SHA512 3df272468c6ea1a1211fd9f1e40bab5be8cdff8cb02556999cde8dde81042d6a0d8ad3958faf507323d7770f6dc2631d9ceba7ade796f8927719ce4a8659ca21
DIST ksysguard-5.14.3.tar.xz 501720 BLAKE2B b3b4ef98ba78c3c30fa76b6914ed93d5a002b1806fc59ad778b27082eb39acdafb68f815743f88cf4d43a4c10cc2de4070603ae5ee18d93a25e7299f0cd0839e SHA512 aa1d2007ffe0b4ad30e3e54a98cb56980d7666a36c879039952a2e589fe054ee773d3b495fbf3605777ed616e90f6f959ade3768e874f45f44223666b398de25
+DIST ksysguard-5.14.4.tar.xz 501544 BLAKE2B c71f517cb923043519f3ce1fffaf0f583e7a10dcdc8ef1125b68771e0aabade329d8b67349b9228990e1c2ef0c7a85d6f42746e670bb2fd4bd21380e27b91a12 SHA512 af59db3d8efd50516e4800e21d6eb6d5236d214b5fb9831065947e803e54a603187d113b3b3582d35be16031d86bc2a374e1440baa943ea421af1d8455400870
diff --git a/kde-plasma/ksysguard/ksysguard-5.14.4.ebuild b/kde-plasma/ksysguard/ksysguard-5.14.4.ebuild
new file mode 100644
index 000000000000..4b2349e1b061
--- /dev/null
+++ b/kde-plasma/ksysguard/ksysguard-5.14.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Network-enabled task manager and system monitor"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="lm_sensors"
+
+DEPEND="
+ $(add_plasma_dep libksysguard '-minimal(-)')
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+RDEPEND="${DEPEND}
+ !kde-plasma/ksysguard:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package lm_sensors Sensors)
+ )
+
+ kde5_src_configure
+}