summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-03-26 20:20:46 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-26 20:55:44 +0100
commitaa2b46cb27d7d34e6b8543ee966b1bec94e69a1d (patch)
treed6706f33f73752cbf20fa088fd0127db9fe36ed3 /kde-plasma/ksshaskpass
parentkde-plasma/kscreenlocker: 6.0.3 version bump (diff)
downloadgentoo-aa2b46cb27d7d34e6b8543ee966b1bec94e69a1d.tar.gz
gentoo-aa2b46cb27d7d34e6b8543ee966b1bec94e69a1d.tar.bz2
gentoo-aa2b46cb27d7d34e6b8543ee966b1bec94e69a1d.zip
kde-plasma/ksshaskpass: 6.0.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-6.0.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 8e659f3989eb..fc0879c2ec49 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.27.11.tar.xz 27980 BLAKE2B 4fa35480f0ed7389bf41f56fc8266fccb8a33060c37f6df2c1edc44f49466267dbd45584e0afff6aaa79a3b5ffc1aca916c36a7ad768e36a457c081bfa53f217 SHA512 85c4091faa4ec4a6d068d4a0d464601054b88187ccfa05f4156b146dd3b3900dc15bcb3f9f9b0b057fb9b5687eabf55bb34d06d98a9e26ddb6a0afba1684feee
DIST ksshaskpass-6.0.2.tar.xz 28884 BLAKE2B d841ae2a0660fa79af2763334bdec473db239f20234eb8c3a53e8f9293b00c5fddedfb3f1698cac3ad4f8593332d259cf1151aa4c09d1f00843db1da9d7b4739 SHA512 8b412be1cdf9a6bd3be5e56f36c2bee44c362431b48db2429e0f8f378f98d83d1022b8934b40675ca4036b4f6dff2cca0a7d7c4227df9be03009f6e01c0bf147
+DIST ksshaskpass-6.0.3.tar.xz 28860 BLAKE2B 819aee1d7061803f3de668d4fbdd0f7c3dd8ac4d083262c97ff1fb3a09925f8f552226c7b4908f660be6b781791bbcb4db8e5c7ddd3e96110f07059a8b34f9e8 SHA512 7d665cb47b762515007d6251534d1d60a54fc26fdc32f8849de36d55d604417682242f8acbb9395d0831ced784a8a0368188fee9b0201dbb9bf2d2f21a03db43
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-6.0.3.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-6.0.3.ebuild
new file mode 100644
index 000000000000..8bd4b1f19279
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-6.0.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.0
+QTMIN=6.6.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[widgets]
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 6,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 6 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+}