summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-10-19 21:04:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-10-20 08:50:44 +0200
commit6a5c98906b670529d289a65f71411b73bc3c7d0d (patch)
treed521fea26c53564d61f0293efa04326ccc4a78bc /kde-plasma/ksshaskpass
parentkde-plasma/kscreenlocker: 5.23.1 version bump (diff)
downloadgentoo-6a5c98906b670529d289a65f71411b73bc3c7d0d.tar.gz
gentoo-6a5c98906b670529d289a65f71411b73bc3c7d0d.tar.bz2
gentoo-6a5c98906b670529d289a65f71411b73bc3c7d0d.zip
kde-plasma/ksshaskpass: 5.23.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.23.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 5ecdf67b128a..6e57d42aaa67 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.22.5.tar.xz 24076 BLAKE2B 2625d07b18b5e1ccd98f5b34e402a4ea201190f3be240ea596e8b4c70f0a15204e7d5ea559a0b17bc253247eca41a988f65bb2e29ee07c2e35600d8a1f761b34 SHA512 35f430882aa735f1b9d7a1874f83fa67074cfb720bbba377d0b38baab2f3eaeddc1598f6f7b9c79479b95d22fdc661d7dfd6835b98a78ea159c68d64abc81a67
DIST ksshaskpass-5.23.0.tar.xz 24080 BLAKE2B b02e16dff364b820e2f23adaf3516efa3dc7829ce31bdef1814dfd46106361bff7a328e694d512f2e9d4a0b129ee0423a3d1a69ab6fb946320052dba16948089 SHA512 4357356ef7a4e81202d9fa7d0e0978ec3be6315c7fd8d46ac081534d9a22f5313c85c028453797158079cde16ba4ca23ba8010c7a606789e0d18f063d6d96ff9
+DIST ksshaskpass-5.23.1.tar.xz 24064 BLAKE2B edfe2e7c439ef346726c73c0ba757cd9d6d7c1b7efb3eb41dcf4a813714f5150bd4366b789bb6ee8212101256424b1fcad3f5a63fa2c8489901bbf6406ebe33b SHA512 6f0483159ef2fe1bc5bbb02d8be440494a1c6cde2516f7f37e8d3e99cbb71e486025ba20853395de49fcf4149d49603342a7e5416382f728f2193ab977d3f50b
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.23.1.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.23.1.ebuild
new file mode 100644
index 000000000000..618cd3f1026f
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.23.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.86.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 dirs
+ rmdir -v "${EROOT}"/etc/plasma{/startup,} 2> /dev/null
+}