summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-09-13 15:42:49 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-09-13 19:43:37 +0200
commit634065008b34e2ecc68eb637381df9a4f352c551 (patch)
treef7ea71ebc3df1905a2188e88871a79f41600c73f /kde-plasma/ksshaskpass
parentkde-plasma/kscreenlocker: 5.27.8 version bump (diff)
downloadgentoo-634065008b34e2ecc68eb637381df9a4f352c551.tar.gz
gentoo-634065008b34e2ecc68eb637381df9a4f352c551.tar.bz2
gentoo-634065008b34e2ecc68eb637381df9a4f352c551.zip
kde-plasma/ksshaskpass: 5.27.8 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.27.8.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 4d42521f4806..be8cddddbcf7 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1 +1,2 @@
DIST ksshaskpass-5.27.7.tar.xz 28040 BLAKE2B 0b757039d42f12118a6ce9f54343c600aab6bc90a87a54dafe30a0f4965e2f6b02b458e56dae90f04de2781e076f61a7b9dd93716b8d4ddd19b9ef6dbe3fa18c SHA512 981351d1d8e4de5a779b3d3c4908f7cdfb1b156efa33b5673c7f35aeda95e69d9da0c1a61af0c44dcfd4fd0f516070b838b7e7ec3ddd70e75b2d35f34e6594bb
+DIST ksshaskpass-5.27.8.tar.xz 28024 BLAKE2B a96857fec5bbcf13dfa93dbbd8317c381a5533de6c86e8253ab5ebb4540fd8f5448f34e55101f04e8adb506e8d424cd15710572235a7390c815e0fd7c1f1b6b6 SHA512 814c6bdfb9ef7da0dafd23c414e131380a14061fb7060e1adb0c721554a2dfd1c57420d1089cd94bc96e5f0b02fca7725513bca57836294f2e8771e0ebe9390a
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.27.8.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.27.8.ebuild
new file mode 100644
index 000000000000..1d6d755de2e8
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.27.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 dirs
+ rmdir -v "${EROOT}"/etc/plasma{/startup,} 2> /dev/null
+}