summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-06-14 08:42:29 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-06-14 10:25:11 +0200
commit5e7871590840f20c22e1140cc868bd54440a17d8 (patch)
treed32e4bfe6275ecac1ceb85dc4e7f9a209a286afc /kde-frameworks
parentkde-frameworks/ktextwidgets: 5.83.0 version bump (diff)
downloadgentoo-5e7871590840f20c22e1140cc868bd54440a17d8.tar.gz
gentoo-5e7871590840f20c22e1140cc868bd54440a17d8.tar.bz2
gentoo-5e7871590840f20c22e1140cc868bd54440a17d8.zip
kde-frameworks/kwallet: 5.83.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kwallet/Manifest1
-rw-r--r--kde-frameworks/kwallet/kwallet-5.83.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/Manifest b/kde-frameworks/kwallet/Manifest
index a63ff8266b69..9d76b6bca743 100644
--- a/kde-frameworks/kwallet/Manifest
+++ b/kde-frameworks/kwallet/Manifest
@@ -1 +1,2 @@
DIST kwallet-5.82.0.tar.xz 300944 BLAKE2B d15119772389a2b422bdc5564d5dd14012eab47ea1767dab0f439db842debd26632a6eb764a33ceb68f0851bbd3ff8bf5101729b8fea1eba6be675608b9cd769 SHA512 b23d0d9229df9060dd71d9ac81247f70bf246f00f6bc0026074be4964532f5e0986c49414d11affbcd88d89de761486e2f3ea2fcb6d023723285e14af85a06cb
+DIST kwallet-5.83.0.tar.xz 300860 BLAKE2B 97227461b33fd5df585c86aaeb0b8f15e8666a8b9d3970375feec2b2fb4ecc9abb8a3c396904c9cd2ef5d11c5eb53bbc738c35862e5c1f5a163e86c522529684 SHA512 ed03b2f967154d6cf8174711870dd7c9e47b5bdc4da0f4f9f62ab16dac020a094794a263a46518a5ee210fcb8eae6d35bf8f1a813ec1b1c40c80732a444ba1e5
diff --git a/kde-frameworks/kwallet/kwallet-5.83.0.ebuild b/kde-frameworks/kwallet/kwallet-5.83.0.ebuild
new file mode 100644
index 000000000000..6958775bab35
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-5.83.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+inherit ecm kde.org optfeature
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="gpg +man"
+
+BDEPEND="
+ man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )
+"
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ gpg? ( >=app-crypt/gpgme-1.7.1[cxx,qt5] )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package gpg Gpgmepp)
+ $(cmake_use_find_package man KF5DocTools)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Auto-unlocking after account login" kde-plasma/kwallet-pam
+ optfeature "KWallet management" kde-apps/kwalletmanager:5
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+ fi
+ ecm_pkg_postinst
+}