summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-11-27 12:54:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-11-27 13:01:40 +0100
commit4bd248579143233dcae2f8d960614fe4119d0124 (patch)
treef18fc6b31611f44f97e8f1df1f2a3fb77a34fe9f /kde-frameworks
parentkde-plasma/kwayland-integration: Drop idletime plugin in 5.25.5 too (diff)
downloadgentoo-4bd248579143233dcae2f8d960614fe4119d0124.tar.gz
gentoo-4bd248579143233dcae2f8d960614fe4119d0124.tar.bz2
gentoo-4bd248579143233dcae2f8d960614fe4119d0124.zip
kde-frameworks/kwindowsystem: Add IUSE wayland to pull in runtime plugin
All other plugins from kde-plasma/kwayland-integration went into respective Frameworks packages and only the kwindowsystem plugin remains, which makes this possible to depend on. It is necessary because kwindowsystem consumers will need the wayland runtime plugin even on non-Plasma systems. This is not exactly pretty but the same exception as dev-qt/qtgui[wayland]. Bug: https://bugs.gentoo.org/790275 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kwindowsystem/kwindowsystem-5.100.0-r1.ebuild44
-rw-r--r--kde-frameworks/kwindowsystem/kwindowsystem-5.99.0-r1.ebuild44
2 files changed, 88 insertions, 0 deletions
diff --git a/kde-frameworks/kwindowsystem/kwindowsystem-5.100.0-r1.ebuild b/kde-frameworks/kwindowsystem/kwindowsystem-5.100.0-r1.ebuild
new file mode 100644
index 000000000000..49367c79de79
--- /dev/null
+++ b/kde-frameworks/kwindowsystem/kwindowsystem-5.100.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework providing access to properties and features of the window manager"
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 ) MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="wayland X"
+
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ X? (
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+ test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
+"
+BDEPEND=">=dev-qt/linguist-tools-${QTMIN}:5"
+PDEPEND="wayland? ( kde-plasma/kwayland-integration:5 )"
+
+DOCS=( docs/README.kstartupinfo )
+
+src_configure() {
+ local mycmakeargs=(
+ -DKWINDOWSYSTEM_NO_WIDGETS=ON
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}
diff --git a/kde-frameworks/kwindowsystem/kwindowsystem-5.99.0-r1.ebuild b/kde-frameworks/kwindowsystem/kwindowsystem-5.99.0-r1.ebuild
new file mode 100644
index 000000000000..0006cc7dcf06
--- /dev/null
+++ b/kde-frameworks/kwindowsystem/kwindowsystem-5.99.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework providing access to properties and features of the window manager"
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 ) MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="wayland X"
+
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ X? (
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+ test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
+"
+BDEPEND=">=dev-qt/linguist-tools-${QTMIN}:5"
+PDEPEND="wayland? ( >=kde-plasma/kwayland-integration-5.25.5-r1:5 )"
+
+DOCS=( docs/README.kstartupinfo )
+
+src_configure() {
+ local mycmakeargs=(
+ -DKWINDOWSYSTEM_NO_WIDGETS=ON
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}