summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-15 12:58:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-15 14:31:55 +0100
commit386a2b3b4aae0468fdce1a80683d2c76287a4d48 (patch)
treebc76153bb555db8f4e32c12072f66894d52d309a /kde-frameworks/syntax-highlighting
parentsys-apps/coreutils: sh stable wrt bug #711616 (diff)
downloadgentoo-386a2b3b4aae0468fdce1a80683d2c76287a4d48.tar.gz
gentoo-386a2b3b4aae0468fdce1a80683d2c76287a4d48.tar.bz2
gentoo-386a2b3b4aae0468fdce1a80683d2c76287a4d48.zip
kde-frameworks: Add KDE Frameworks 5.68.0
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/syntax-highlighting')
-rw-r--r--kde-frameworks/syntax-highlighting/Manifest1
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.68.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/Manifest b/kde-frameworks/syntax-highlighting/Manifest
index e59edd895738..6b343b72ddfb 100644
--- a/kde-frameworks/syntax-highlighting/Manifest
+++ b/kde-frameworks/syntax-highlighting/Manifest
@@ -1 +1,2 @@
DIST syntax-highlighting-5.67.0.tar.xz 1582228 BLAKE2B 5b51e7336f79993229bec7a6e22715bbb6803b301c97755d6139d4cdba1d446d0273cab435eeca9bf0967c5ddaefcf9cecc09d8a229985ff9fa210c29f384620 SHA512 a14cabfe29da936668dff441334dada4a12b98d6bed9cca991bcb8f80529b681fe8c49d5ee14081ab8410b5d82bc411d9b03baa340c8f5fef245dab8767913a7
+DIST syntax-highlighting-5.68.0.tar.xz 1594860 BLAKE2B 6f8aaf22d183b04ef358b8db052f43a58d1453d7a17f63ac252b5554740446277a3296e4fafc20efd5c4d81f6e6f70c5a67acf1412b5cb3157569b0a86c82de1 SHA512 ffb4b1e57bd912ed76c93b8ea074af3fd8343cd094a584647bef42870366cd089c6ba2070670a57e4997ba6ac122775af5066d5bae4891f3533e4b7bfecf1fee
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.68.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.68.0.ebuild
new file mode 100644
index 000000000000..d9a5fcd1c7cb
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.68.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Framework for syntax highlighting"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-lang/perl
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+ dobin "${BUILD_DIR}"/bin/katehighlightingindexer
+}