summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-10 19:43:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-10 22:30:21 +0100
commit20de7eb6efa5c734f2d09e5d9d74dc54a4dec075 (patch)
tree9b9ee1de2e1f7de589b6309673591645abe4a665 /kde-frameworks/syntax-highlighting
parentkde.org.eclass: Standard HOMEPAGE for kde-plasma and kde-frameworks (diff)
downloadgentoo-20de7eb6efa5c734f2d09e5d9d74dc54a4dec075.tar.gz
gentoo-20de7eb6efa5c734f2d09e5d9d74dc54a4dec075.tar.bz2
gentoo-20de7eb6efa5c734f2d09e5d9d74dc54a4dec075.zip
kde-frameworks: Add KDE Frameworks 5.64.0
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/syntax-highlighting')
-rw-r--r--kde-frameworks/syntax-highlighting/Manifest1
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.64.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/Manifest b/kde-frameworks/syntax-highlighting/Manifest
index 5bbad8028ec4..8fcf05ab0a7e 100644
--- a/kde-frameworks/syntax-highlighting/Manifest
+++ b/kde-frameworks/syntax-highlighting/Manifest
@@ -1,2 +1,3 @@
DIST syntax-highlighting-5.60.0.tar.xz 1490716 BLAKE2B 77d15a0b294726eae8aa1fa7f8983062442d96e41c6aa183637f89078541f93c5ba05894c5b14d42ae9c03c852d2612afd25949e707f5aea3b6e1faf11294b19 SHA512 266e1df814e3b6383068347238c6d8a46736112b4d0037784361b9b756a9f00ca29ce615185dbb553568fec9dca97671c95d1d39dde1f40a864c1ff40174ec15
DIST syntax-highlighting-5.63.0.tar.xz 1573164 BLAKE2B 9d63b645972c7b1e5eaf64a91a0df156774ebb54fcd3c6c180603de694802f4cc24e66b697cf0476cfff8e67243b6a766bd0fdf366d99f30499cb1ff16b9b0ac SHA512 e696c5e7f1dac0bd088fd0b4140fd531e027c185b49b663f3e1e7296a36b31425d4d65f126ee99aa6a42c2c12cc660ccbf0e120ea08960c926a72f7c6b772d26
+DIST syntax-highlighting-5.64.0.tar.xz 1572812 BLAKE2B 5e1b7de3bab10fb912e3c3d0d07d84a6ced1cf12b955a9a09ce4d94f3f150edd05a98334a9373a85f928b1fae8df709b0f51327f600b43402520ffeb9a44071f SHA512 3310651de68409190a203eae1e05bfad1742b656ad66a0f6e49eae9ac00e896300d10780675ca0687982c6dee2fafa5880955c86c67e8149637c8fa52842d4c7
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.64.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.64.0.ebuild
new file mode 100644
index 000000000000..a21e01eb924d
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.64.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Framework for syntax highlighting"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-lang/perl
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+ dobin "${BUILD_DIR}"/bin/katehighlightingindexer
+}