summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-04-11 11:47:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-11 11:50:05 +0200
commit0349ea09ca07221a2e9f442196f7722c4debd752 (patch)
tree6645baf9a02fc5af5f70593e90a8fae31ec609d9 /kde-frameworks/sonnet/sonnet-5.69.0.ebuild
parentsci-libs/gdal: arm64 stable (bug #699838) (diff)
downloadgentoo-0349ea09ca07221a2e9f442196f7722c4debd752.tar.gz
gentoo-0349ea09ca07221a2e9f442196f7722c4debd752.tar.bz2
gentoo-0349ea09ca07221a2e9f442196f7722c4debd752.zip
kde-frameworks: Add KDE Frameworks 5.69.0
Package-Manager: Portage-2.3.98, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/sonnet/sonnet-5.69.0.ebuild')
-rw-r--r--kde-frameworks/sonnet/sonnet-5.69.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/sonnet-5.69.0.ebuild b/kde-frameworks/sonnet/sonnet-5.69.0.ebuild
new file mode 100644
index 000000000000..93eac7f8dfbf
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.69.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="aspell +hunspell nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package aspell ASPELL)
+ $(cmake_use_find_package hunspell HUNSPELL)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # bugs: 680032
+ local myctestargs=(
+ -E "(sonnet-test_settings|sonnet-test_highlighter)"
+ )
+
+ ecm_src_test
+}