summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-09 11:50:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-09 13:31:40 +0200
commit78d3baee6a4c834139f8030a632e31db75cab0c6 (patch)
tree97353bfd1f6a7a440e3975e56e8b4ed8e8a01c26 /kde-frameworks/purpose
parentapp-text/libmspub: Fix build with GCC 10, EAPI-7 bump (diff)
downloadgentoo-78d3baee6a4c834139f8030a632e31db75cab0c6.tar.gz
gentoo-78d3baee6a4c834139f8030a632e31db75cab0c6.tar.bz2
gentoo-78d3baee6a4c834139f8030a632e31db75cab0c6.zip
kde-frameworks: Add KDE Frameworks 5.70.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.70.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index 809a9a71e370..7e1cc5a6bd9c 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,2 +1,3 @@
DIST purpose-5.67.0.tar.xz 156680 BLAKE2B 1bfd4d78eac52162d71bdb8e827eccd4e65a1ce907b87a069f5c188f3f51746b380f6b8d678b7ae74e94b6187e9fe0dc4789bc0cbf2d653e00d286fca5e174b9 SHA512 5035ba1edb62bd6e4d9fcd9aabff94f9c74d795862e787006a4586463a8d809f2b148a47b06ccf7db1039978ed91ef15c65148bbe662396f0f76268931a8d069
DIST purpose-5.69.0.tar.xz 153840 BLAKE2B 1836f0c5f80bdd56e21b007ade9a9da866e9cf62d6992be3fdb74afa5af78f0e72c1e7cfc73fbd9af0f69d7083637a44b2220784dc8a04eaf89c09092d782120 SHA512 cf72c168c3aa0bd77eb86a078e18feed976484082fe2b135e3e8b85962980431d226f22ee3ee541f4d4a90a1314ac88fe79d60774d4db5c54f87b1ec745c0b87
+DIST purpose-5.70.0.tar.xz 153468 BLAKE2B e918c824658b52829607ba9ddf727178d2689aa64f5caa075dbf0947ca53819f6b8a15d49df1d3c4a408a7017cfc63416a46af2466ca51e16c7383c45b799060 SHA512 932fc3a56c47a3a031f4acc32ae5ea04733c99f953ce3248e60bc47b836d26929e71bb10633c3859d642c8667e4b1dbb60f03f450da8b0c2bda703142cf80916
diff --git a/kde-frameworks/purpose/purpose-5.70.0.ebuild b/kde-frameworks/purpose/purpose-5.70.0.ebuild
new file mode 100644
index 000000000000..1bebde506a67
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.70.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="+dolphin +kaccounts"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ dolphin? ( =kde-frameworks/knotifications-${PVCUT}*:5 )
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+# requires running environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package dolphin KF5Notifications)
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst(){
+ ecm_pkg_postinst
+
+ if ! has_version "kde-misc/kdeconnect[app]" ; then
+ elog "Optional runtime dependency:"
+ elog "kde-misc/kdeconnect[app] (send through KDE Connect)"
+ fi
+}