summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-13 13:14:10 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-13 13:17:03 +0100
commit2fd629605fa726f1fd8b00cef54620dab7e2c0b8 (patch)
tree401b89777cd64ee396def7bcd60e4b87f5558a60 /kde-frameworks/purpose
parentkde-frameworks/plasma: 5.80.0 version bump (diff)
downloadgentoo-2fd629605fa726f1fd8b00cef54620dab7e2c0b8.tar.gz
gentoo-2fd629605fa726f1fd8b00cef54620dab7e2c0b8.tar.bz2
gentoo-2fd629605fa726f1fd8b00cef54620dab7e2c0b8.zip
kde-frameworks/purpose: 5.80.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.80.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index dc1d74ed1cca..cb98ea755205 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,2 +1,3 @@
DIST purpose-5.77.0.tar.xz 158016 BLAKE2B 51e26b284bbeb8ac07690f4b9c571f58b89c977e87a5bdad8f56a5aaacb69b2d1130b08169fcdc7848925b1811d4e632e4c3e9c453e30482a4ed80c4d329c81f SHA512 61261ae4d5ae2327100629ace3e6b2cade9b2894bb21e817700a1265c5283b13a6f828bec47dfd8efa118fadad0f5cc89cbf8fd3e637497dd68345eefaa53956
DIST purpose-5.79.0.tar.xz 159496 BLAKE2B 3743b29591663a4f2e3d5b8ff0e1ca7d236dd9aacac2759fe7f3e7c52ba2cd2e7f43627c51bc45cb33cfd4f7dc222646bfc0b937d42918bb92caa78b045e08d7 SHA512 e9e61f06013a47ff18ade96f1d43465026f07a5163fc443c21c2d9bf9d56435a121a8f7ce8c3e554cb2c0ec1d80795907ae8199a0fd5b81e59f5fd6f32b2f0e3
+DIST purpose-5.80.0.tar.xz 159308 BLAKE2B e7467c3ca5a39c2482c470aa55debbb29b3e0457271a9f126e4b68dc1c48db245bb1d7adb73fdff6f3bdd044fb99557bc08cf2a72de5cab998dd7a9485002641 SHA512 3746e66f0587ad0b7f62f0c262879a6f2f8a58af3753f6c4a1f28ca4996fa40ad63accb5d024fbef1269b137b45c38234cde0bfc5a046cf1c66b61064a7809b4
diff --git a/kde-frameworks/purpose/purpose-5.80.0.ebuild b/kde-frameworks/purpose/purpose-5.80.0.ebuild
new file mode 100644
index 000000000000..e9607e015d71
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.80.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+inherit ecm kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="bluetooth +kaccounts"
+
+# requires running environment
+RESTRICT+=" test"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:5 )
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Optional dependencies:"
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}