summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-03-13 09:53:10 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-03-13 20:22:10 +0100
commit1f0ef3ca4f7e37a78987d6a392940a620e2972ba (patch)
tree3b4e7fb5ee76ecb9631ffb350193c771c7d723e8 /kde-frameworks/purpose
parentkde-frameworks/plasma: 5.92.0 version bump (diff)
downloadgentoo-1f0ef3ca4f7e37a78987d6a392940a620e2972ba.tar.gz
gentoo-1f0ef3ca4f7e37a78987d6a392940a620e2972ba.tar.bz2
gentoo-1f0ef3ca4f7e37a78987d6a392940a620e2972ba.zip
kde-frameworks/purpose: 5.92.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.92.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index 35668aff80b3..175b346407cd 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,2 +1,3 @@
DIST purpose-5.90.0.tar.xz 171204 BLAKE2B 5319b0d1d20a77b35503180f8276752a8478bfccd1f80fe7564aa590c786a64517d2c0484fd5596cfdbe2635c6933f931d8ab43609d8b168a3766de2dea1fcc3 SHA512 8ba0808eba826ed267e42b9d8e9fd247482e964b104f0e68fd73b02862c13486c24d5bdc9cdf22f4912ad1edb49855d113f209d6690463aaec247bacd3ad0154
DIST purpose-5.91.0.tar.xz 172796 BLAKE2B ab42e9ae3e548dda194ea73dda2bb4d94ee19b3f40adf108535300309409da3b3a6842e5bc101f7e92ceb839f7807bb3c21b05fbf757400d79ad7f1150d43747 SHA512 d2bf6f99b7836ae0bfda6bfb7ee231b35952514d774b13cbbab6e6aa99b6a6e0c9148ed11ecf1c6baccd9b5e6a1566390852b069ad59f1402ac03ed2ca7ef200
+DIST purpose-5.92.0.tar.xz 173280 BLAKE2B 4cbed1b8b9b8a443fdb9ecbaf6495918c1f21f641184827a5e6af4084b5b2beb5b5f4a0a8c4d8e593ac4a4222dfc702e5b2ac5330625a3d26962f986d0ff07f1 SHA512 e466b836d4628f8773247cb952621d9c33127c26ae73c27b9f8015239997b0f7241a0f556c8c683a2a580c3977f448b1e9742965d9133e2c569d42b2d6cf2009
diff --git a/kde-frameworks/purpose/purpose-5.92.0.ebuild b/kde-frameworks/purpose/purpose-5.92.0.ebuild
new file mode 100644
index 000000000000..0d2e408ffe68
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.92.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+inherit ecm kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="bluetooth +kaccounts"
+
+# requires running environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/prison-${PVCUT}*:5
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:5 )
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}