summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-13 22:01:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-13 22:13:21 +0200
commit1876675b11a8c8dbef64473485a901bc6e11cfd8 (patch)
tree1651b3d54a239928ebfda3ac55b37725a8260e62 /kde-frameworks/purpose
parentkde-frameworks/kxmlgui: 6.2.0 version bump (diff)
downloadgentoo-1876675b11a8c8dbef64473485a901bc6e11cfd8.tar.gz
gentoo-1876675b11a8c8dbef64473485a901bc6e11cfd8.tar.bz2
gentoo-1876675b11a8c8dbef64473485a901bc6e11cfd8.zip
kde-frameworks/purpose: 6.2.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-6.2.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index 0695c546af1b..a5fd9f2a7c1e 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,2 +1,3 @@
DIST purpose-5.115.0.tar.xz 180012 BLAKE2B 2e5a2805b19384f5e8ce0fdb94fa5cc3a7dbfeaaac027e45d95cc16091ea94e2a626ebb8be34f67838ea48049496005588ee6055f745b332676a64a35450c30e SHA512 b17cd780ed7947582fbc71430de67ebeaf33432113bbb77fba3736bd608d05fb132d40f7783cba4fdfd7ab3eec60f00676d48be0ce9c601c37f8eccc04d4db31
DIST purpose-6.1.0.tar.xz 175584 BLAKE2B 02cabc4ff679560bad0bc77d853f97ac5b4a27e2e20c5ac0ca86ce932aa2c8ed1d8e2d24d1ff5c39513903baefea772289fd99307bcbb13282d3499205712b24 SHA512 a52b365c3e33966e2557529d63a9cab8af66d1ea976a47e9aeee62755897bada371ad16f758abefb47201728e371f050c40fd88d29b9584445b4c816e954ff78
+DIST purpose-6.2.0.tar.xz 177088 BLAKE2B 55eb988d13fc49e77b77ff8ca25ada6574be9e7bbf7943806f41cc2c7500f43fbe2e6bfcde72ea232fec3a4b702455114f4cbb5790019f0c7791e224664b8954 SHA512 6eaf12c4a2c85b201a8cc3fdd321f5c99274b467b3785fcc4ceed1016873433b71bbb14b1d1b97dd81baa94c5dd22a34d41813948d799b4a6a2fdd7ede0d28c6
diff --git a/kde-frameworks/purpose/purpose-6.2.0.ebuild b/kde-frameworks/purpose/purpose-6.2.0.ebuild
new file mode 100644
index 000000000000..644569f4d542
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-6.2.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.2
+inherit ecm frameworks.kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64"
+IUSE="bluetooth kaccounts"
+
+# requires running environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/kcoreaddons-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/kio-${PVCUT}*:6
+ =kde-frameworks/kirigami-${PVCUT}*:6
+ =kde-frameworks/knotifications-${PVCUT}*:6
+ =kde-frameworks/kservice-${PVCUT}*:6
+ =kde-frameworks/prison-${PVCUT}*:6
+ kaccounts? (
+ kde-apps/kaccounts-integration:6
+ >=net-libs/accounts-qt-1.16_p20220803[qt6]
+ )
+"
+RDEPEND="${DEPEND}
+ !${CATEGORY}/${PN}:5[-kf6compat(-)]
+ >=kde-frameworks/kdeclarative-${PVCUT}:6
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:6 )
+ kaccounts? ( >=net-libs/accounts-qml-0.7_p20231028[qt6] )
+"
+BDEPEND="kaccounts? ( dev-util/intltool )"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package kaccounts KAccounts6)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}