summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-09-13 12:45:37 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-09-13 15:19:45 +0200
commit08fe1983fe970971d8fae7cff5d628c83a0d2705 (patch)
treee3f1c0f4c7e2433cd21f81ad80bc1ceb7a45f38a /kde-frameworks/purpose
parentkde-frameworks/plasma: 5.98.0 version bump (diff)
downloadgentoo-08fe1983fe970971d8fae7cff5d628c83a0d2705.tar.gz
gentoo-08fe1983fe970971d8fae7cff5d628c83a0d2705.tar.bz2
gentoo-08fe1983fe970971d8fae7cff5d628c83a0d2705.zip
kde-frameworks/purpose: 5.98.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.98.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index 7de9231b97b5..dbd870957305 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,2 +1,3 @@
DIST purpose-5.96.0.tar.xz 172284 BLAKE2B 3a272ea568d862ed4c300a45dbf6c3d5eee6b9dd1a6b8bc1f9c08535375ae9bac1233514ca8b6bafc20febce4b42efd773fe8415dfd7156222cbe3302d33d7c2 SHA512 80ede3300842db1a1e2553525c47f0d8d5d8611c6fd5509b2e864f1832b468326c38f70fd1a9588260660c4aff6ac7264d8dade55a5c255a9b46cb4aff2445b7
DIST purpose-5.97.0.tar.xz 174884 BLAKE2B 2743795bdb8e8e0872304178f0eb3433a0520526eb4eb728f4633e9cef0202df8e5e0edb9b0cb6937c1512873b256dea7f42040dacaf54496b0b090e522d2707 SHA512 be5f66b961bca62a32fffe886ae205db6d4531e2ef05952bae383637df47d538e1beefaf495c06a9f2213b237f742384094e981096598a79fe8bbcf9046bc447
+DIST purpose-5.98.0.tar.xz 174904 BLAKE2B a4cadd69aff680fbe41b6a93e18756b8a05a82fb43c8c2e55c2805ddbcc3829b7327d8f3a2e799a61220eb0caa29ec8998e507914ba75eabe36203f2f6ee9324 SHA512 3fff666a64a6ff82fec7e109a3118078179b971692f6b62dac72c7204b345b481766f2366b8d799674fb73633dc76c9aefe457d4f18ae733afb9e7a47fc18eb6
diff --git a/kde-frameworks/purpose/purpose-5.98.0.ebuild b/kde-frameworks/purpose/purpose-5.98.0.ebuild
new file mode 100644
index 000000000000..977f6624605a
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.98.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+inherit ecm frameworks.kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="bluetooth +kaccounts"
+
+# requires running environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/prison-${PVCUT}*:5
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:5 )
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}