summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-10 14:15:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-11 23:00:24 +0100
commita37abaa67c24e28e5e853a9f9e8ed3381ceff877 (patch)
treee82c32cd1411c52fe9216880222174a0ef3c2bd9 /kde-frameworks/kwallet
parentapp-admin/keepassxc: updating 9999 for new build options and deps (diff)
downloadgentoo-a37abaa67c24e28e5e853a9f9e8ed3381ceff877.tar.gz
gentoo-a37abaa67c24e28e5e853a9f9e8ed3381ceff877.tar.bz2
gentoo-a37abaa67c24e28e5e853a9f9e8ed3381ceff877.zip
kde-frameworks: Add KDE Frameworks 5.43.0
Bug: https://bugs.gentoo.org/647306 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'kde-frameworks/kwallet')
-rw-r--r--kde-frameworks/kwallet/Manifest1
-rw-r--r--kde-frameworks/kwallet/kwallet-5.43.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/Manifest b/kde-frameworks/kwallet/Manifest
index 7f5759988906..efd166cad376 100644
--- a/kde-frameworks/kwallet/Manifest
+++ b/kde-frameworks/kwallet/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-5.40.0.tar.xz 306244 BLAKE2B 84fbefe01377d3c960274c9750fb7eecf3c0f45143004a35a9b331f197b84a807fb37655ad9793d0f4c8e29781ab30d0c09977ea24acd196a4eeeddd07254e58 SHA512 a162d5ed1901fe3c8675f715ddb9a32640d7b563bf0755a7add885208a8f55465d9082d2abb9553d411018d3a5a4856b17efc94789dbd5993ac6f11a8a0c71c8
DIST kwallet-5.42.0.tar.xz 306540 BLAKE2B 7aabef63f3455c947d84d531f5181ba97364cac8e0e29264599acbac7e94df2f8bad154a097f6bec187f4e35bf98568fbefeac7e002e9d61d667911ecb829997 SHA512 800eca462be0f95d5f0c41aef8cbf5513b5599cea988c49fe94dddc5803ec2834acde0f44a83d4739cef120cbfca5807c523c3b5a7a7f07f1ee3372fe5e63987
+DIST kwallet-5.43.0.tar.xz 306848 BLAKE2B fbeac0ae4df91dde98840c3c88da30d43ce7ffa0fb4f18a5d51f0d15921d613804b235b0aba81c113ade1faba979ce105eaba956fcb9958a092925afc589d133 SHA512 38d129c45b1c2282c1e09a01fc9316b30b0d3f3c53f1b56dba295f732a2aaf5dab7759ca40b46ec80985d773a59a4ecddfc6edbe7fca7beb59c3392dab44e13b
diff --git a/kde-frameworks/kwallet/kwallet-5.43.0.ebuild b/kde-frameworks/kwallet/kwallet-5.43.0.ebuild
new file mode 100644
index 000000000000..9ebbc724defc
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-5.43.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="gpg +man"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/libgcrypt:0=
+ gpg? ( >=app-crypt/gpgme-1.7.1[cxx,qt5] )
+"
+DEPEND="${RDEPEND}
+ man? ( $(add_frameworks_dep kdoctools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package gpg Gpgmepp)
+ $(cmake-utils_use_find_package man KF5DocTools)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ if ! has_version "kde-plasma/kwallet-pam" || ! has_version "kde-apps/kwalletmanager:5" ; then
+ elog
+ elog "Install kde-plasma/kwallet-pam for auto-unlocking after account login."
+ elog "Install kde-apps/kwalletmanager:5 to manage your kwallet."
+ elog
+ fi
+ if has_version "kde-apps/kwalletd"; then
+ elog "Starting with 5.34.0-r1, ${PN} is able to serve applications"
+ elog "that still require old kwalletd4. After migration has finished,"
+ elog "kde-apps/kwalletd can be removed."
+ fi
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+}