summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-12 22:52:21 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-13 07:18:41 +0200
commitf8ac5e6537a09fcc6120edacf419d3f7c8b51313 (patch)
tree7d79d8b55ae2cadc8dd30833751c4099555f14f6 /kde-frameworks/kquickcharts
parentkde-frameworks/kplotting: 5.86.0 version bump (diff)
downloadgentoo-f8ac5e6537a09fcc6120edacf419d3f7c8b51313.tar.gz
gentoo-f8ac5e6537a09fcc6120edacf419d3f7c8b51313.tar.bz2
gentoo-f8ac5e6537a09fcc6120edacf419d3f7c8b51313.zip
kde-frameworks/kquickcharts: 5.86.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kquickcharts')
-rw-r--r--kde-frameworks/kquickcharts/Manifest1
-rw-r--r--kde-frameworks/kquickcharts/kquickcharts-5.86.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/kde-frameworks/kquickcharts/Manifest b/kde-frameworks/kquickcharts/Manifest
index fb51aafdaef6..7acc95deb066 100644
--- a/kde-frameworks/kquickcharts/Manifest
+++ b/kde-frameworks/kquickcharts/Manifest
@@ -1,2 +1,3 @@
DIST kquickcharts-5.82.0.tar.xz 105832 BLAKE2B 00bd1f5ff89e11758607a9b6c2705d4c670107b18eb5ac67522b1f5a6ba5f4b5897b86582ad6ea5f2a1e9245efdf52614a6ee418ff0c2ff8a0499de5211bfe49 SHA512 978e9644d62a3bc7c9e5fddbc7ce67551941a2429804d93a5745584c28555a748f7804287162e31217082bb9e9391d2d86bb50eda209f93da15cb4b5c93ed583
DIST kquickcharts-5.85.0.tar.xz 105940 BLAKE2B a7b3b4b16602ab030102310e8a94ad3ea64d5e9fa3db60e12ddd947a9c2385976ad80755608896cc22c2fd3c884a3ec8b1969f95002b2c1313d64ed688cafce7 SHA512 ea5e7187a15e715d8e6359cfb08696030243c190fd70ccbf60e82ded22a24170dfe3eac3963ccc44782c5fc7beee6e398435d08fe1b5bc19c26386fa83645f30
+DIST kquickcharts-5.86.0.tar.xz 108384 BLAKE2B 8149800011242d32438f38db5140db909b8f6d0a261de3ac1163f923d184073a8e92f2594f03d390bfa79425cfbb89ceca3b40f38febe07e78a1a9e53b05e17f SHA512 a64a446b5c1c8e66ffd4a5ee0519e6ef373636d2232b486ea27402359a027f886544690f017457c77f08ca02e9d9ee8a47ee302e08b47a36bbe0717647247957
diff --git a/kde-frameworks/kquickcharts/kquickcharts-5.86.0.ebuild b/kde-frameworks/kquickcharts/kquickcharts-5.86.0.ebuild
new file mode 100644
index 000000000000..d4f10a50a5bf
--- /dev/null
+++ b/kde-frameworks/kquickcharts/kquickcharts-5.86.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_EXAMPLES="true"
+ECM_QTHELP="false"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="QtQuick plugin providing high-performance charts"
+HOMEPAGE="https://invent.kde.org/frameworks/kquickcharts"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ examples? (
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kdeclarative-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=$(usex examples)
+ )
+
+ ecm_src_configure
+}